2009-12-18 12:37:45     CM-BF548 gpio driver doesnt load

Document created by Aaronwu Employee on Aug 20, 2013
Version 1Show Document
  • View in full screen mode

2009-12-18 12:37:45     CM-BF548 gpio driver doesnt load

Tom Wimmer (GERMANY)

Message: 83704   

 

Hello, i build my kernel with the latest branch 2.6.28.10-ADI-2009R1 and  uClinux-dist-2009R1-RC6.

 

As described in the documentation i enable

 

CONFIG_GENERIC_GPIO=y

 

CONFIG_ARCH_WANT_OPTIONAL_GPIOLIB=y

 

CONFIG_GPIOLIB=y

 

But theres NO response like

 

"Blackfin GPIO Controller" in the kernel messages

 

and no /sys/class/gpio.

 

Also in the kernel config theres no:

[ ]   /sys/class/gpio/... (sysfs interface)

 

What can i do? Try another/newer Kernel version? Where to find that?!

 

Thanks for your time!

 

QuoteReplyEditDelete

 

 

2009-12-18 12:45:13     Re: CM-BF548 gpio driver doesnt load

Mike Frysinger (UNITED STATES)

Message: 83705   

 

i see the GPIO sysfs interface just fine in my 2009R1 CM-BF548 config.  are you sure you're looking in the right place ?

QuoteReplyEditDelete

 

 

2009-12-18 12:53:47     Re: CM-BF548 gpio driver doesnt load

Tom Wimmer (GERMANY)

Message: 83706   

 

Yes, quite sure:

 

[*] GPIO Support  --->

 

--- GPIO Support                                                                                

  │ │                                  *** Memory mapped GPIO expanders: ***                                                     

  │ │                                  *** I2C GPIO expanders: ***                                                               

  │ │                                  *** PCI GPIO expanders: ***                                                               

  │ │                                  *** SPI GPIO expanders: ***                                                               

  │ │                            < >   Maxim MAX7301 GPIO expander                                                     

  │ │                            < >   Microchip MCP23S08 I/O expander

 

 

 

Should be a sub of "GPIO Support" in "Device Drivers" right?

QuoteReplyEditDelete

 

 

2009-12-18 12:56:02     Re: CM-BF548 gpio driver doesnt load

Mike Frysinger (UNITED STATES)

Message: 83707   

 

looks like you disabled SYSFS and/or EXPERIMENTAL then.  dont do that.

QuoteReplyEditDelete

 

 

2009-12-18 12:58:20     Re: CM-BF548 gpio driver doesnt load

Tom Wimmer (GERMANY)

Message: 83708   

 

Yes, it was the experimental thing ;-)

 

Thanks a lot!

Attachments

    Outcomes