2009-11-23 13:08:15     backport linphone

Document created by Aaronwu Employee on Aug 19, 2013
Version 1Show Document
  • View in full screen mode

2009-11-23 13:08:15     backport linphone

daniel amor (SPAIN)

Message: 82657   

 

Hi verybody,

 

 

 

We have a board running uClinux 2008R1.5-RC3, the distribution is stable and we have developed some custom drivers to support the surrounding hardware.

 

 

 

We are trying to get a newer version of linphone running. I downloaded the sources of osip, eXosip and linphone from 2009R1-RC6 and also trunk. I have been able to compile both osip and eXosip, but whne trying to get linphone I get the following error:

 

 

 

mkdir .libs

libtool: link: cannot find the library `/usr/lib/libosipparser2.la' or unhandled argument `/usr/lib/libosipparser2.la'

make[7]: *** [linphonec] Error 1

make[7]: Leaving directory `/home/user/uClinux-dist-2008R1.5-RC3/user/blkfin-apps/linphone/build-linphone-3.0.0/console'

make[6]: *** [all-recursive] Error 1

make[6]: Leaving directory `/home/user/uClinux-dist-2008R1.5-RC3/user/blkfin-apps/linphone/build-linphone-3.0.0'

make[5]: *** [all] Error 2

make[5]: Leaving directory `/home/user/uClinux-dist-2008R1.5-RC3/user/blkfin-apps/linphone/build-linphone-3.0.0'

make[4]: *** [all] Error 2

make[4]: Leaving directory `/home/user/uClinux-dist-2008R1.5-RC3/user/blkfin-apps/linphone'

make[3]: *** [all] Error 2

make[3]: Leaving directory `/home/user/uClinux-dist-2008R1.5-RC3/user/blkfin-apps'

make[2]: *** [blkfin-apps] Error 2

make[2]: Leaving directory `/home/user/uClinux-dist-2008R1.5-RC3/user'

make[1]: *** [all] Error 2

make[1]: Leaving directory `/home/user/uClinux-dist-2008R1.5-RC3/user'

make: *** [subdirs] Error 1

(CHROOTA0Aa):~/uClinux-dist-2008R1.5-RC3$

 

 

 

I used the Makefile for linphone in 2008 version and changed some bits to accomodate it for the new sources, mainly the version number.

 

 

 

Does everybody know why it is looking for the library in that path?

 

 

 

Thanks for your time and all the solutions propossed in this list.

TranslateQuoteReplyEditDelete

 

 

2009-11-23 15:01:47     Re: backport linphone

Mike Frysinger (UNITED STATES)

Message: 82661   

 

you need to fix the libtool linker scripts to not use paths to the host system

QuoteReplyEditDelete

 

 

2009-11-23 15:29:46     Re: backport linphone

daniel amor (SPAIN)

Message: 82663   

 

Thanks for your fast response.

 

 

 

Could you tell me how to do it? or at least which kind of files should I look for.

 

 

 

Thanks again.

TranslateQuoteReplyEditDelete

 

 

2009-11-23 15:44:53     Re: backport linphone

Mike Frysinger (UNITED STATES)

Message: 82664   

 

i told you the files already -- the libtool linker scripts (*.la)

QuoteReplyEditDelete

 

 

2009-11-23 15:49:03     Re: backport linphone

daniel amor (SPAIN)

Message: 82665   

 

Ok, thanks, I'll check all *.la files involved.

 

 

 

Thanks for your help.

Attachments

    Outcomes