2009-11-22 09:07:19     can not boot from image!

Document created by Aaronwu Employee on Aug 19, 2013
Version 1Show Document
  • View in full screen mode

2009-11-22 09:07:19     can not boot from image!

zhang zhihua (CHINA)

Message: 82625   

 

when I reset the board,it appears:

 

VFS: Cannot open root device "mtdblock0" or unknown-block(0,0)

Please append a correct "root=" boot option; here are the available partitions:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

 

I want to creat password for the telnet,someone tel me to modify the busybox,so when build the kernel,slected the

 

Busybox-->

 

   Login/Password Management Utilities-->

 

     [*] getty   

 

     [*] login

 

     [*] passwd

 

     [*] su

 

but after loaded the vmImage to the board,it can not boot!

 

if I unslect the busybox,it can start normal!How to set the Environment Variables?

TranslateQuoteReplyEditDelete

 

 

2009-11-22 12:40:20     Re: can not boot from image!

Mike Frysinger (UNITED STATES)

Message: 82626   

 

once again, you arent using the right forum.  in fact, i dont think you've asked a single u-boot question yet.  please stop posting questions to the u-boot forum.

 

you also shouldnt lump a bunch of unrelated questions at the same time.

 

all of your questions are covered in the documentation.  please search the wiki.

 

  depot/dokuwiki/doku.php?id=uclinux-dist:rootfs

  depot/dokuwiki/doku.php?id=uclinux-dist:shell

Attachments

    Outcomes