2009-11-03 07:34:57     SL811HS problems with SCSI Mode

Document created by Aaronwu Employee on Aug 19, 2013
Version 1Show Document
  • View in full screen mode

2009-11-03 07:34:57     SL811HS problems with SCSI Mode

Patrick Hotz (GERMANY)

Message: 82035   

 

Hi,

 

i have a problem with my SL811HS USB-Chip or my SCSI Devices....

 

First my Hardware:    uClinux-dist2008R1.5

                                      BF537 @ 500Mhz/100Mhz

                                      SL811HS on AMS3 / IRQ = PF9 / RST = PF8

 

My Kernel-Config:     the same as at "  docs.blackfin.uclinux.org/doku.php?id=hw:cards:usb_ez-extender" described

 

 

 

I want to test my USB-Host with a 4GB USB-Stick....

I see that the kernel is booting like the example:

 

".....

sl811: driver sl811-hcd, 19 May 2005

sl811-hcd sl811-hcd.0: SL811HS v1.5

sl811-hcd sl811-hcd.0: new USB bus registered, assigned bus number 1

sl811-hcd sl811-hcd.0: irq 59, io mem 0x20340000

usb usb1: configuration #1 chosen from 1 choice

hub 1-0:1.0: USB hub found

hub 1-0:1.0: 1 port detected

Initializing USB Mass Storage driver...

usbcore: registered new interface driver usb-storage

USB Mass Storage support registered.

.......

usb 1-1: new full speed USB device using sl811-hcd and address 2

usb 1-1: configuration #1 chosen from 1 choice

scsi0 : SCSI emulation for USB Mass Storage devices

.......

scsi 0:0:0:0: Direct-Access              blue ice USB     1100 PQ: 0 ANSI: 0 CCS

sd 0:0:0:0: [sda] 7864320 512-byte hardware sectors (4027 MB)

sd 0:0:0:0: [sda] Write Protect is off

sd 0:0:0:0: [sda] Assuming drive cache: write through

sd 0:0:0:0: [sda] 7864320 512-byte hardware sectors (4027 MB)

sd 0:0:0:0: [sda] Write Protect is off

sd 0:0:0:0: [sda] Assuming drive cache: write through

sda: sda1

sd 0:0:0:0: [sda] Attached SCSI removable disk

.......

"

 

But i can´t see any "sda"-Device in my "/dev/"......

This is in my "/proc"

 

"

root:/> cd proc

root:/proc> cd scsi

root:/proc/scsi> cat scsi

Attached devices:

Host: scsi0 Channel: 00 Id: 00 Lun: 00

  Vendor:          Model: blue ice USB     Rev: 1100

  Type:   Direct-Access                    ANSI  SCSI revision: 00

root:/proc/scsi> cd usb-storage

root:/proc/scsi/usb-storage> cat 0

   Host scsi0: usb-storage

       Vendor: Unknown

      Product: blue ice USB

Serial Number: AA04012700007478

     Protocol: Transparent SCSI

    Transport: Bulk

       Quirks:

root:/proc/scsi/usb-storage>

"

 

I think i have the right settings in my board file because the USB-Stick is identified correctly.....

 

Is there a way to activate the sda-device in my "/dev" ??

 

 

 

Best regards,

Patrick

TranslateQuoteReplyEditDelete

 

 

2009-11-03 07:51:12     Re: SL811HS problems with SCSI Mode

Patrick Hotz (GERMANY)

Message: 82036   

 

OK,

 

big sorry !!!!!!!

I have forgotten to try a "mdev -s".... now i can find my stick and mount it.....

 

 

 

Patrick

Attachments

    Outcomes