2009-09-29 05:07:41     microperl (___umulsi3_highpart)

Document created by Aaronwu Employee on Aug 19, 2013
Version 1Show Document
  • View in full screen mode

2009-09-29 05:07:41     microperl (___umulsi3_highpart)

Kostantin Sheshko (RUSSIAN FEDERATION)

Message: 80632   

 

Hi, have a problem

 

BF-532 and BF-533

 

kernel:    Linux release 2.6.22.18-ADI-2008R1-svn, build #73 Wed Nov 5 18:12:42 CST 2008

toolchain: bfin-linux-uclibc-gcc release gcc version 4.1.2 (ADI svn)

user-dist: release 2008R1, build #43 Wed Nov 5 18:13:36 CST 2008

 

 

 

i try to run microperl and php from packages

 

> ipkg install perl

Come pkg_info_preinstall_check this line 1625

Installing perl (5.8.6-1) to root...

Downloading http://rowetel.com/ucasterisk/ipkg/./perl_5.8.6-1_bfin.ipk

Configuring pagecache

/proc/sys/vm/pagecache_ratio: cannot create

postinst script returned status 255

ERROR: pagecache.postinst returned 255

Configuring perl

Done.

 

 

but microperl is now pressent in system....

then i try to run microperl:

 

>microperl

microperl: can't resolve symbol '___umulsi3_highpart'

 

 

 

who can help me?

QuoteReplyEditDelete

 

 

2009-09-29 09:31:28     Re: microperl (___umulsi3_highpart)

Robin Getz (UNITED STATES)

Message: 80635   

 

Kostantin:

 

We don't support ipkg yet. That is something that the astfin folks did. You might want to ask there.

 

-Robin

QuoteReplyEditDelete

 

 

2009-09-29 16:44:09     Re: microperl (___umulsi3_highpart)

Mike Frysinger (UNITED STATES)

Message: 80653   

 

that symbol comes from gcc's libgcc_s.so.  if microperl isnt linked against the lib, it means it wasnt compiled correctly.  talk to the people who compiled it like Robin suggested.

QuoteReplyEditDelete

Attachments

    Outcomes