2009-09-07 08:17:17     Mounting JFFS2 file system on Flash

Document created by Aaronwu Employee on Aug 19, 2013
Version 1Show Document
  • View in full screen mode

2009-09-07 08:17:17     Mounting JFFS2 file system on Flash

razia razia (INDIA)

Message: 79641   

 

Hi,

 

I am working with

 

Board: ADSP BF527-0.2 Custom Board

 

Flash Chip: CFI compliant 16MB Parallel NOR Flash

 

Linux version 2.6.28.10-ADI-2009R1

 

uClinux -distribution: uClinux-dist-2009R1-RC1.

 

Using mkfs.jffs2 in mtd utils, I created an image rootfs.jffs2 and copied tthis jffs2 image to one MTD partition /dev/mtd2

 

After giving the command,

 

root:/> mount -t jffs2 /dev/mtdblock2 /mnt

 

I am getting the following console messages

 

Empty flash at 0x0000fffc ends at 0x00010000

CLEANMARKER node found at 0x00010000, not first node in block (0x00000000)

Empty flash at 0x0002fffc ends at 0x00030000

CLEANMARKER node found at 0x00030000, not first node in block (0x00020000)

Empty flash at 0x0004fffc ends at 0x00050000

CLEANMARKER node found at 0x00050000, not first node in block (0x00040000)

Empty flash at 0x0006fffc ends at 0x00070000

CLEANMARKER node found at 0x00070000, not first node in block (0x00060000)

Empty flash at 0x0008fffc ends at 0x00090000

CLEANMARKER node found at 0x00090000, not first node in block (0x00080000)

 

But the file system got mounted on,

 

root:/> ls mnt

bin   dev   etc   home  lib   mnt   proc  root  sbin  sys   tmp   usr   var

 

Please tell me why these messages are displayed? Is there any error in the mounting process?

 

How to avoid these messages?

 

TIA

QuoteReplyEditDelete

 

 

2009-09-07 08:52:14     Mounting JFFS2 file system on Flash

Michael Hennerich (GERMANY)

Message: 79648   

 

Check this out:

  docs.blackfin.uclinux.org/doku.php?id=linux-kernel:jffs&s[]=cleanmarker#troubleshooting

you can avoid these warnings, by giving mkfs.jffs2 the right options.

 

-Michael

QuoteReplyEditDelete

 

 

2009-09-08 00:30:13     Re: Mounting JFFS2 file system on Flash

razia razia (INDIA)

Message: 79661   

 

Hi Michael,

 

Thanks for your suggestion. I gave the correct erase size and the warnings are not observed on Mounting.

Attachments

    Outcomes