2009-08-10 03:23:46     MTD flash driver doubts

Document created by Aaronwu Employee on Aug 16, 2013
Version 1Show Document
  • View in full screen mode

2009-08-10 03:23:46     MTD flash driver doubts

Harbhajan Singh (INDIA)

Message: 78545   

 

Hi,

 

I am working with the custom board with BF53x chip, 2009R1-RC1 distribution.

 

currently our h/w is in designing phase not completely finalised,

 

from the mtd/chips drivers i found there is support for the flash chips with

 

command set 0x0001, command set 0x0002 and command set 0x0020

 

If we choose flash chip which has a different command set for e.g., 0x0003 will any of this drivers will work? or we need to do some code modifications.

 

could you please clarify my doubt on this.

 

Thank you.

QuoteReplyEditDelete

 

 

2009-08-10 03:41:54     Re: MTD flash driver doubts

Graf Yang (CHINA)

Message: 78547   

 

The cmd set 0001, 0003, and 0200 use the same cmd set  0001 in driver.

2009-08-08 12:31:44     TWI driver doubts

Harbhajan Singh (INDIA)

Message: 78537   

 

Hi,

 

I am working with uClinux distribution 2009R1-RC1 custom board with BF527 processor.

 

on the custom board three i2c devices are connected to BF527 TWI.

 

I have opened the i2c driver in the following method.

 

i2c_fd = open("dev/i2c-0", O_RDWR);

 

if ( (ret = ioctl(i2c_fd,I2C_SLAVE,addr)) < 0) {

                i2c_debug("slave with address = 0x%02x is not found \\n",addr<<1);

                return -1;

        }

for controlling the individual device i will change the SLAVE ADDR(I2C_SLAVE) like in the above ioctl call and then control the device from the user appplication.

 

Is this method is correct or will it create any problem.

 

Please provide your suggestion.

 

Thank you.

QuoteReplyEditDelete

 

 

2009-08-09 23:27:36     Re: TWI driver doubts

Sonic Zhang (CHINA)

Message: 78540   

 

Yes, correct.

Attachments

    Outcomes