2009-07-20 22:41:58     tftp boot problem

Document created by Aaronwu Employee on Aug 16, 2013
Version 1Show Document
  • View in full screen mode

2009-07-20 22:41:58     tftp boot problem

chandu v (MALAYSIA)

Message: 77781   

 

hello,

 

i loaded uImage.537.ast  to my Bf537-stamp(Rev 0.3) previously via  tftp but, suddenly it's not booting now.

 

here is the o/p

 

bf537> print

bootdelay=2

baudrate=57600

loads_echo=1

autoload=no

rootpath=/romfs

gatewayip=192.168.0.1

netmask=255.255.255.0

hostname=BF537

loadaddr=0x1000000

ramargs=setenv bootargs root=/dev/mtdblock0 rw

nfsargs=setenv bootargs root=/dev/nfs rw nfsroot=$(serverip):$(rootpath)

addip=setenv bootargs $(bootargs) ip=$(ipaddr):$(serverip):$(gatewayip):$(netmask):$(hostname):eth0:off

ramboot=tftpboot $(loadaddr) linux;run ramargs;run addip;bootelf

nfsboot=tftpboot $(loadaddr) linux;run nfsargs;run addip;bootelf

update=tftpboot $(loadaddr) u-boot.bin;protect off 0x20000000 0x2007FFFF;erase 0x20000000 0x2007FFFF;cp.b 0x1000000 0x20000000 $(filesize)

ethact=BF537 ETHERNET

filesize=E6C8

ethaddr=00:e0:22:fe:5c:65

flashboot=bootm 0x20020000

bootargs=root=/dev/mtdblock0 rw

bootcmd=run flashboot

serverip=10.44.29.165

ipaddr=10.44.29.239

stdin=serial

stdout=serial

stderr=serial

 

Environment size: 865/8188 bytes

 

 

 

 

bf537> tftp 0x1000000 uIamge.537.ast

Using BF537 ETHERNET device

TFTP from server 10.44.29.165; our IP address is 10.44.29.239

Filename 'uIamge.537.ast'.

Load address: 0x1000000

Loading: T

 

 

 

root:~> ifconfig

lo        Link encap:Local Loopback

          inet addr:127.0.0.1  Mask:255.0.0.0

          UP LOOPBACK RUNNING  MTU:16436  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

 

am not getting eth0 when i give the "ifconfig " command

 

help me pls where the error coming

 

Regards

 

chandu

 

QuoteReplyEditDelete

 

 

2009-07-21 16:10:25     Re: tftp boot problem

Mike Frysinger (UNITED STATES)

Message: 77788   

 

verify your tftp server is running and accessible from other machines (i.e. no firewall)

 

for Linux, please read the documentation:

  docs.blackfin.uclinux.org/doku.php?id=setting_up_the_network

QuoteReplyEditDelete

 

 

2009-07-22 01:55:55     Re: tftp boot problem

chandu v (MALAYSIA)

Message: 77811   

 

Hi mike,

 

thanks for the sugession

 

now i can boot uImage .

 

Regards

 

chandu

Attachments

    Outcomes