2009-07-09 03:55:46     ADV7393 test pattern

Document created by Aaronwu Employee on Aug 16, 2013
Version 1Show Document
  • View in full screen mode

2009-07-09 03:55:46     ADV7393 test pattern

suresh kumar (INDIA)

Message: 76949   

 

Hi

 

We are designed new uclinux based board.

 

 

 

we are using only 8-bit data connection between adv7393 and PPI(Upper 8-bit).we are provideing 27MHz clock input to adv7393 encoder.

 

 

 

So i need to change the driver for 8bit data trasfer.

 

First i am checking the test pattern.

 

The code is here:

 

static const u8 init_NTSC_TESTPATTERN[] = {

        0x00, 0x1C,             /*Power up all DACs. PLL off */

        0x02, 0x20,             /*Composite output (CVBS), color bar */

        0x82, 0xCB,             /*Step control on, pixel data valid, pedestal on, PrPb SSAF on, CVBS/YC output.*/

        0x84, 0xC0,             /* CBVS Color Bar Test Pattern Enabled, DAC 2 = Luma, DAC 3 = Chroma */

};

 

 

static const u8 init_NTSC_TESTPATTERN_BLACK[] = {

        0x00, 0x1C,             /*Power up all DACs. PLL off */

        0x02, 0x24,             /*Composite output (CVBS), black bar */

        0x82, 0xCB,             /*Step control on, pixel data valid, pedestal on, PrPb SSAF on, CVBS/YC output.*/

        0x84, 0x40,             /*SD Color Bar Test Pattern Enabled, DAC 2 = Luma, DAC 3 = Chroma */

};

 

 

 

What would be the output.

 

I am connecting DAC1 output into TV.

 

I am geeting some some DOT color output in TV.

 

I am not sure is it correct output.

 

Help me in this issue.

 

 

 

Suresh

Attachments

    Outcomes