2009-07-03 02:19:42     Does the wm8731 driver in 2009R1 work?

Document created by Aaronwu Employee on Aug 16, 2013
Version 1Show Document
  • View in full screen mode

2009-07-03 02:19:42     Does the wm8731 driver in 2009R1 work?

david wang (CHINA)

Message: 76727   

 

Hi, all

 

  I have a wm8731 chip in my board , which connected the bf527 by SPORT 1. I found there are a ALSA wm8731 driver in the 2009R1 sound driver. How to use it?  I enable the option Build all ASoC CODEC driver, but when the board start , it report no sound card found , and no /dev/dsp could be found under /dev. Below is the dump,

 

/////skip

 

Advanced Linux Sound Architecture Driver Version 1.0.18rc3.

ASoC version 0.13.2

ALSA device list:

  No soundcards found.

/////skip

 

ls: /dev/dsp: No such file or directory

 

 

 

  Need I choose SoC I2S Audio for the ADI BF5xx chip option also? but, when I enable that option ,I got a compile error like below,

 

  MODPOST 32 modules

ERROR: "sport_set_tx_callback" [sound/soc/blackfin/snd-bf5xx-i2s.ko] undefined!

ERROR: "sport_config_tx_dma" [sound/soc/blackfin/snd-bf5xx-i2s.ko] undefined!

ERROR: "sport_set_rx_callback" [sound/soc/blackfin/snd-bf5xx-i2s.ko] undefined!

ERROR: "sport_curr_offset_tx" [sound/soc/blackfin/snd-bf5xx-i2s.ko] undefined!

ERROR: "sport_curr_offset_rx" [sound/soc/blackfin/snd-bf5xx-i2s.ko] undefined!

ERROR: "sport_tx_stop" [sound/soc/blackfin/snd-bf5xx-i2s.ko] undefined!

ERROR: "sport_done" [sound/soc/blackfin/snd-bf5xx-i2s.ko] undefined!

ERROR: "sport_rx_stop" [sound/soc/blackfin/snd-bf5xx-i2s.ko] undefined!

ERROR: "sport_config_rx_dma" [sound/soc/blackfin/snd-bf5xx-i2s.ko] undefined!

ERROR: "sport_handle" [sound/soc/blackfin/snd-bf5xx-i2s.ko] undefined!

ERROR: "sport_rx_start" [sound/soc/blackfin/snd-bf5xx-i2s.ko] undefined!

ERROR: "sport_tx_start" [sound/soc/blackfin/snd-bf5xx-i2s.ko] undefined!

QuoteReplyEditDelete

 

 

2009-07-03 02:27:19     Re: Does the wm8731 driver in 2009R1 work?

Mike Frysinger (UNITED STATES)

Message: 76729   

 

we dont test any wolfson codecs.  most likely you need to write your own machine driver to bind a codec to a transport.  please review the documentation in linux-2.6.x/Documentation/sound/alsa/soc/ or contact wolfson for support.

QuoteReplyEditDelete

Attachments

    Outcomes