2009-06-08 20:00:46     2008SVN branch error for 533-Stamp Board

Document created by Aaronwu Employee on Aug 15, 2013
Version 1Show Document
  • View in full screen mode

2009-06-08 20:00:46     2008SVN branch error for 533-Stamp Board

Lukasz Jaruszewski (POLAND)

Message: 75372   

 

Hi all,

 

I have downloaded SVN branch uImage-SVN-r8215-bf533-stamp from   blackfin.uclinux.org/gf/project/uclinux-dist/frs web site. I loaded it into the RAM through kermit app and when I tried to execute by "go 0x1000000" command, showed me following error messages:

 

bfin> loadb 0x1000000

## Ready for binary (kermit) download to 0x01000000 at 57600 bps...

## Total Size      = 0x003f0b1e = 4131614 Bytes

## Start Addr      = 0x01000000

bfin> go 0x1000000

## Starting application at 0x01000000 ...

 

 

Ack! Something bad happened to the Blackfin!

 

SEQUENCER STATUS:

SEQSTAT: 00000021  IPEND: 7fc00bc  SYSCFG: 0032

HWERRCAUSE: 0x0

EXCAUSE   : 0x21

physical IVG7 asserted : <0x07fc0764> { _evt_default + 0x0 }

RETE: <0xf25b100a> { ___smulsi3_highpart + 0xea5d7eee }

RETN: <0xfa0b11a8> { ___smulsi3_highpart + 0xf20d808c }

RETX: <0x01000000> /* unknown address */

RETS: <0x07fccf1a> { _do_go + 0x62 }

PC  : <0x07fc00bc> { _start + 0xbc }

DCPLB_FAULT_ADDR: <0xffe00004> { __etext_l1 + 0x3fffcc }

ICPLB_FAULT_ADDR: <0x01000000> /* unknown address */

 

PROCESSOR STATE:

R0 : 00000001    R1 : 07f5bec8    R2 : 07f5ba92    R3 : ffffffff

R4 : 00000000    R5 : 00000000    R6 : 07f5bec8    R7 : 00000001

P0 : 00000007    P1 : 00000128    P2 : ffe00004    P3 : 00000002

P4 : 01000000    P5 : 07f5c000    FP : 07f5bcd0    SP : 07f5bab8

LB0: 07fd90e4    LT0: 07fd90d8    LC0: 00000000

LB1: 07fc65ae    LT1: 07fc65a8    LC1: 00000000

B0 : 56c89ffc    L0 : 00000000    M0 : 64c8e82f    I0 : 01000000

B1 : 3f9e6ed9    L1 : 00000000    M1 : eec4efbf    I1 : 07f5bf40

B2 : f63ef9ed    L2 : 00000000    M2 : b46846f1    I2 : 56eb2e39

B3 : d4c56ae9    L3 : 00000000    M3 : bdee29bd    I3 : cd8bbc7b

A0.w: 00000000   A0.x: 00000000   A1.w: 00000000   A1.x: 00000000

USP : 704f7c5d  ASTAT: 00001004

     

Hardware Trace:

0 Target : <0x07fc0504> { _bfin_panic + 0x0 }

Source : <0x07fc068e> { _trap_c + 0x14a }

1 Target : <0x07fc0682> { _trap_c + 0x13e }

Source : <0x07fc0560> { _trap_c + 0x1c }

2 Target : <0x07fc0544> { _trap_c + 0x0 }

Source : <0x07fc070a> { _trap + 0x56 }

3 Target : <0x07fc06b4> { _trap + 0x0 }

Source : <0x07fccf18> { _do_go + 0x60 }

4 Target : <0x07fccf12> { _do_go + 0x5a }

Source : <0x07fc74e6> { _dcache_disable + 0x1a }

5 Target : <0x07fc74cc> { _dcache_disable + 0x0 }

Source : <0x07fccf0e> { _do_go + 0x56 }

6 Target : <0x07fccf0a> { _do_go + 0x52 }

Source : <0x07fc74ae> { _dcache_status + 0x12 }

7 Target : <0x07fc749c> { _dcache_status + 0x0 }

Source : <0x07fccf06> { _do_go + 0x4e }

8 Target : <0x07fccf06> { _do_go + 0x4e }

Source : <0x07fc7486> { _icache_disable + 0x1a }

9 Target : <0x07fc746c> { _icache_disable + 0x0 }

Source : <0x07fccf02> { _do_go + 0x4a }

10 Target : <0x07fccefe> { _do_go + 0x46 }

Source : <0x07fc749a> { _icache_status + 0x12 }

11 Target : <0x07fc7488> { _icache_status + 0x0 }

Source : <0x07fccefa> { _do_go + 0x42 }

12 Target : <0x07fccefa> { _do_go + 0x42 }

Source : <0x07fd2142> { _printf + 0x42 }

13 Target : <0x07fd2138> { _printf + 0x38 }

Source : <0x07fc08ac> { _serial_puts + 0x1c }

14 Target : <0x07fc08a0> { _serial_puts + 0x10 }

Source : <0x07fc087c> { _serial_putc + 0x48 }

15 Target : <0x07fc0868> { _serial_putc + 0x34 }

Source : <0x07fc0874> { _serial_putc + 0x40 }

                                                                   

Please reset the board

                                                                   

### ERROR ### Please RESET the board ###

 

I have to use some GPIO pins and I was advised that 2008 SVN branch have simple gpio driver implemented. Do you have any suggestions why this uImage is not working for me? Maybe I should try with some other uImage?

 

I will be very grateful for any suggestions and pieces of advice.

 

Lukasz

QuoteReplyEditDelete

 

 

2009-06-08 20:06:23     Re: 2008SVN branch error for 533-Stamp Board

Mike Frysinger (UNITED STATES)

Message: 75373   

 

please read the documentation:

  docs.blackfin.uclinux.org/doku.php?id=bootloaders:u-boot:uimage

QuoteReplyEditDelete

 

 

2009-06-09 11:35:37     Re: 2008SVN branch error for 533-Stamp Board

Lukasz Jaruszewski (POLAND)

Message: 75409   

 

Mike:

 

Thank you again

 

I mixed up a little with commands.. I forgot that "go" command I was using for execute u-boot, not uImage (for it is "bootm" command).

 

Everything is working as designed and I'm able to using GPIO's from user space at last. I'm using GPIO sysfs Interface, which is better solution than Simple GPIO Driver, I think.

 

Many thanks espacially for Mike, for his support.

 

Lukasz

Attachments

    Outcomes