2009-05-15 02:31:46     I conn't login in uclinux

Document created by Aaronwu Employee on Aug 15, 2013
Version 1Show Document
  • View in full screen mode

2009-05-15 02:31:46     I conn't login in uclinux

suresh kumar (INDIA)

Message: 74087   

 

Hi

 

I am using bf537-stamp .

 

I can able to ping from board to pc and reverse also.

 

===========The board default ip is ==========

 

root:~> ifconfig

lo        Link encap:Local Loopback

          inet addr:127.0.0.1  Mask:255.0.0.0

          UP LOOPBACK RUNNING  MTU:16436  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:0

 

 

 

==========My PC IP is================

 

[root@localhost ~]# ifconfig

eth0      Link encap:Ethernet  HWaddr 00:80:48:24:73:35 

          inet addr:127.0.0.2  Bcast:127.255.255.255  Mask:255.0.0.0

          inet6 addr: fe80::280:48ff:fe24:7335/64 Scope:Link

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

          RX packets:0 errors:0 dropped:0 overruns:0 frame:0

          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0

          collisions:0 txqueuelen:1000

          RX bytes:0 (0.0 b)  TX bytes:468 (468.0 b)

          Interrupt:21 Base address:0x6c00

 

 

=====ping from borad to pc======

 

root:~> ping 127.0.0.2

PING 127.0.0.2 (127.0.0.2): 56 data bytes

64 bytes from 127.0.0.2: icmp_seq=0 ttl=64 time=0.4 ms

64 bytes from 127.0.0.2: icmp_seq=1 ttl=64 time=0.2 ms

64 bytes from 127.0.0.2: icmp_seq=2 ttl=64 time=0.2 ms

 

--- 127.0.0.2 ping statistics ---

3 packets transmitted, 3 packets received, 0% packet loss

round-trip min/avg/max = 0.2/0.2/0.4 ms

 

 

======== ping from PC to  board================

 

 

[root@localhost ~]# ping 127.0.0.1

PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.

64 bytes from 127.0.0.1: icmp_seq=1 ttl=64 time=0.041 ms

64 bytes from 127.0.0.1: icmp_seq=2 ttl=64 time=0.042 ms

64 bytes from 127.0.0.1: icmp_seq=3 ttl=64 time=0.036 ms

64 bytes from 127.0.0.1: icmp_seq=4 ttl=64 time=0.050 ms

64 bytes from 127.0.0.1: icmp_seq=5 ttl=64 time=0.036 ms

64 bytes from 127.0.0.1: icmp_seq=6 ttl=64 time=0.035 ms

64 bytes from 127.0.0.1: icmp_seq=7 ttl=64 time=0.039 ms

64 bytes from 127.0.0.1: icmp_seq=8 ttl=64 time=0.041 ms

64 bytes from 127.0.0.1: icmp_seq=9 ttl=64 time=0.045 ms

 

--- 127.0.0.1 ping statistics ---

9 packets transmitted, 9 received, 0% packet loss, time 7999ms

rtt min/avg/max/mdev = 0.035/0.040/0.050/0.008 ms

 

 

 

When i try to login with use of telnet

 

i cann't login

 

i give the username as root

 

password as uClinux

 

As per as the uclinux Docs---

 

  docs.blackfin.uclinux.org/doku.php?id=basic_compilation

 

The default username for the Blackfin login is root and the password is uClinux.

 

 

 

 

 

i cann't trace the problem.....

 

 

 

 

 

Suresh

 

QuoteReplyEditDelete

 

 

2009-05-15 04:50:27     Re: I conn't login in uclinux

Mike Frysinger (UNITED STATES)

Message: 74100   

 

i think you need to review basic network documentation.  127.0.0.1 is routed to the local machine all the time, it will certainly not allow you to talk to a different machine.

 

please read the documentation:

  docs.blackfin.uclinux.org/doku.php?id=setting_up_the_network

Attachments

    Outcomes