2009-05-05 14:44:29     Problem building modules with 2008R1.5-RC3

Document created by Aaronwu Employee on Aug 15, 2013
Version 1Show Document
  • View in full screen mode

2009-05-05 14:44:29     Problem building modules with 2008R1.5-RC3

Jay Ku (UNITED STATES)

Message: 73692   

 

I'm trying to build a custom version of 2008R1.5-RC3 for my BF532 board.  After disabling lots of stuff to get it to build the kernel, I'm here:

 

  ...

  MODPOST vmlinux

  OBJCOPY arch/blackfin/boot/vmlinux.bin

  GZIP    arch/blackfin/boot/vmlinux.gz

  UIMAGE  arch/blackfin/boot/vmImage

Image Name:   Linux-2.6.22.19-ADI-2008R1.5

Created:      Mon May  4 20:08:22 2009

Image Type:   Blackfin Linux Kernel Image (gzip compressed)

Data Size:    1008272 Bytes = 984.64 kB = 0.96 MB

Load Address: 0x00001000

Entry Point:  0x001AE000

Kernel: arch/blackfin/boot/vmImage is ready

  Building modules, stage 2.

  MODPOST 694 modules

WARNING: drivers/rtc/rtc-test.o(.data+0x4): Section mismatch: reference to .exit.text:_test_remove (between '_test_drv' and '_dev_attr_irq')

WARNING: net/decnet/decnet.o(.data+0x4fc): Section mismatch: reference to .init.data:_addr (between '___param_arr_addr' and '_max_priority')

ERROR: "csum_partial_copy_from_user" [net/rxrpc/af-rxrpc.ko] undefined!

ERROR: "vm_insert_page" [net/packet/af_packet.ko] undefined!

ERROR: "ip_compute_csum" [net/ipv4/ip_gre.ko] undefined!

ERROR: "filemap_nopage" [fs/xfs/xfs.ko] undefined!

ERROR: "filemap_populate" [fs/xfs/xfs.ko] undefined!

ERROR: "filemap_nopage" [fs/ocfs2/ocfs2.ko] undefined!

ERROR: "filemap_nopage" [fs/gfs2/gfs2.ko] undefined!

ERROR: "uart_console_device" [drivers/serial/bfin_5xx.ko] undefined!

ERROR: "uart_set_options" [drivers/serial/bfin_5xx.ko] undefined!

ERROR: "uart_parse_options" [drivers/serial/bfin_5xx.ko] undefined!

ERROR: "vm_insert_page" [drivers/scsi/scsi_tgt.ko] undefined!

make[1]: *** [__modpost] Error 1

make: *** [modules] Error 2

devel@devel-desktop:~/blackfin_tools/uClinux-dist-2008R1.5-RC3/linux-2.6.x$

 

I've done a couple of searches but I'm not sure what to do now.  Any advice?

QuoteReplyEditDelete

 

 

2009-05-05 15:42:39     Re: Problem building modules with 2008R1.5-RC3

Robin Getz (UNITED STATES)

Message: 73694   

 

Jay:

 

You turned off things you need. You need to figure out where the symbols exist, and turn things back on (either built in, or as a module).

 

-Robin

QuoteReplyEditDelete

 

 

2009-05-08 15:35:56     Re: Problem building modules with 2008R1.5-RC3

Jay Ku (UNITED STATES)

Message: 73900   

 

Started over using BF533-STAMP_defconfig as a starting point.... linux now running on my board... very cool!

QuoteReplyEditDelete

Attachments

    Outcomes