2009-05-05 13:52:20     request to add libmodbus to trunk

Document created by Aaronwu Employee on Aug 15, 2013
Version 1Show Document
  • View in full screen mode
2009-05-05 13:52:20 request to add libmodbus to trunk

 

Kyle Schlansker (UNITED STATES)

 

Message: 73682  

 

Is it possible to add the latest release (2.0.3) of libmodbus to trunk before the 2009R1 branch?  You can get the sources here:  launchpad.net/libmodbus/+download

 

Thanks.

 

QuoteReplyEditDelete

 

2009-05-05 15:53:58 Re: request to add libmodbus to trunk

 

Robin Getz (UNITED STATES)

 

Message: 73696  

 

Kyle:

 

I would say no problem - but this is the first one that I'm aware of that would include any GPL/LGPL v3 into something that runs on the target. (Unless Mike can correct me, and something else slipped in).

 

Do you need v2.0.3 or is libmodbus v1.2.5 (which is still under LGPL 2) OK?

 

-Robin

 

QuoteReplyEditDelete

 

2009-05-05 16:51:38 Re: request to add libmodbus to trunk

 

Mike Frysinger (UNITED STATES)

 

Message: 73704  

 

readline is GPL-3.  whether the library is GPL-2 or GPL-3 doesnt matter that much ... any library that isnt LGPL means any project linking against it needs to be GPL.  licensing problems are the end user's problem though ;).

 

ive added libmodbus-2.0.3 to the tree.

 

QuoteReplyEditDelete

 

2009-05-06 11:06:32 Re: request to add libmodbus to trunk

 

Kyle Schlansker (UNITED STATES)

 

Message: 73767I don't think the licensing issues will be a problem, but just to check my understanding: I'm working under the assumption that if program X links against libmodbus then program X needs to be GPL. If that's not a good assumption then let me know

 

QuoteReplyEditDelete

 

2009-05-06 11:36:40 Re: request to add libmodbus to trunk

 

Robin Getz (UNITED STATES)

 

Message: 73773  

 

Kyle:

 

The best place to get legal/licensing advice from is not us.

 

https://docs.blackfin.uclinux.org/doku.php?id=copyright_information#software_license

 

Also check out the FSF faq:

 

  www.gnu.org/licenses/gpl-faq.html

 

specifically -

 

  www.gnu.org/licenses/gpl-faq.html#AllCompatibility

 

I just didn't think there were any other GPL v3 applications in the dist - Mike corrected me - so yeah, I don't have a problem with it (Mike added the latest yesterday) - it is up to you on how you combine things, and meet the requirements of each license.

 

-Robin

 

QuoteReplyEditDelete

 

2009-05-06 11:53:27 Re: request to add libmodbus to trunk

 

Kyle Schlansker (UNITED STATES)

 

Message: 73775  

 

Thanks for the links Robin, and thank you for adding it to the tree Mike.

Attachments

    Outcomes