2009-04-29 09:48:45     Kernal Build Error

Document created by Aaronwu Employee on Aug 15, 2013
Version 1Show Document
  • View in full screen mode

2009-04-29 09:48:45     Kernal Build Error

Jim Carstensen (UNITED STATES)

Message: 73431   

 

Hello -

 

Trying to build kernal from trunk.  Checked out yesterday afternoon (4/28).

 

Full log of terminal session attached.  Last few lines are here:

 

if test ! -d e2fsck && test ! -d debugfs && test ! -d misc && test ! -d ext2ed ; then make install-libs ; fi

make[4]: Leaving directory `/home/alcorn/blackfin-sources/uclinux-dist/user/e2fsprogs/build-e2fsprogs-1.41.4'

make DVI=true MAKEINFO=true post-build

make[4]: Entering directory `/home/alcorn/blackfin-sources/uclinux-dist/user/e2fsprogs'

make[4]: Nothing to be done for `post-build'.

make[4]: Leaving directory `/home/alcorn/blackfin-sources/uclinux-dist/user/e2fsprogs'

/home/alcorn/blackfin-sources/uclinux-dist/tools/cross-fix-root

make[3]: Leaving directory `/home/alcorn/blackfin-sources/uclinux-dist/user/e2fsprogs'

make[2]: Leaving directory `/home/alcorn/blackfin-sources/uclinux-dist/user'

make[1]: *** [all] Error 2

make[1]: Leaving directory `/home/alcorn/blackfin-sources/uclinux-dist/user'

make: *** [subdirs] Error 1

alcorn@alcorn-linux:~/blackfin-sources/uclinux-dist$

 

 

 

Config is default, except added mp3play, pcmcia, and ntfs file system.

 

Any ideas?

 

thanks,

 

JC

 

log1.log

QuoteReplyEditDelete

 

 

2009-04-29 10:47:06     Re: Kernal Build Error

Robin Getz (UNITED STATES)

Message: 73432   

 

Jim:

 

Can you try "make single"

 

-Robin

QuoteReplyEditDelete

 

 

2009-04-29 10:49:03     Re: Kernal Build Error

Jim Carstensen (UNITED STATES)

Message: 73433   

 

A bit more info on this...

 

Checked kernal defaults in the config and got a successful build.

 

I need to figure out what I need to select, and if I select it, whether it will build successfully.

 

Here's what I want to do:

 

Using a BF537 Stamp with AD1836 board and CF/IDE-ATA/NAND Extender.

 

Robin hooked me up with an image that decoded MP3 (MP3Play) from the CF card, and also could stream MP3 from the Enet interface.  Seems simple enough.

 

Tried my best to duplicate the menuconfig selections, but build failed (see first thread entry).

 

Any suggestions as to how to make proper selections in the config in order to get back to what Robin first provided, and result in a successful build?

 

thanks,

 

JC

 

QuoteReplyEditDelete

 

 

2009-04-29 12:09:15     Re: Kernal Build Error

Jim Carstensen (UNITED STATES)

Message: 73437   

 

Tried the 'make single'

 

Here's how it ended...

 

r: redefinition of ‘struct group_filter’

/home/alcorn/blackfin-sources/build/bfin-uclinux/bfin-uclinux/runtime/usr/include/linux/in.h:174: error: redefinition of ‘struct in_pktinfo’

/home/alcorn/blackfin-sources/build/bfin-uclinux/bfin-uclinux/runtime/usr/include/linux/in.h:182: error: redefinition of ‘struct sockaddr_in’

nfsmount.c: In function ‘nfsmount’:

nfsmount.c:237: error: ‘NFS_VERSION’ undeclared (first use in this function)

nfsmount.c:237: error: (Each undeclared identifier is reported only once

nfsmount.c:237: error: for each function it appears in.)

nfsmount.c:118: warning: unused variable ‘hp’

make[4]: *** [nfsmount.o] Error 1

make[4]: Leaving directory `/home/alcorn/blackfin-sources/uclinux-dist/user/mount'

make[3]: *** [mount] Error 2

make[3]: Leaving directory `/home/alcorn/blackfin-sources/uclinux-dist/user'

make[2]: *** [all] Error 2

make[2]: Leaving directory `/home/alcorn/blackfin-sources/uclinux-dist/user'

make[1]: *** [subdirs] Error 1

make[1]: Leaving directory `/home/alcorn/blackfin-sources/uclinux-dist'

make: *** [single] Error 2

alcorn@alcorn-linux:~/blackfin-sources/uclinux-dist$

 

 

 

This is with the following menuconfig selections:

 

Filesystem applications --> mount

 

Network applications --> ifconfig

 

Miscellaneous applications --> mp3play

 

 

 

Kernal:

 

Bus Options --> PC Card * Blackfin Compact Flash PCMCIA (NEW)

 

File System--> DOS/FAT FS  MSDOS NTFS

 

 

 

What next?

 

Thanks,

 

JC

 

 

QuoteReplyEditDelete

 

 

2009-04-29 13:00:24     Re: Kernal Build Error

Jim Carstensen (UNITED STATES)

Message: 73439   

 

Robin:

 

I removed the 'mount' selection in the Filesystem applications and after 'make cleean' and 'make single' it worked.

 

BTW. What does 'make single' do compared to just 'make'?

 

thanks,

 

JC

 

 

QuoteReplyEditDelete

 

 

2009-04-29 13:02:46     Re: Kernal Build Error

Robin Getz (UNITED STATES)

Message: 73440   

 

Turn off "mount"

 

CONFIG_USER_MOUNT_MOUNT should be no.

 

rgetz@imhotep:~/blackfin/trunk/uClinux-dist> grep CONFIG_USER_MOUNT_MOUNT ./config/.config

# CONFIG_USER_MOUNT_MOUNT is not set

 

 

-Robin

QuoteReplyEditDelete

 

 

2009-04-29 13:12:58     Re: Kernal Build Error

Robin Getz (UNITED STATES)

Message: 73443   

 

Jim:

 

https://docs.blackfin.uclinux.org/doku.php?id=target_selection#various_targets

 

-Robin

Attachments

Outcomes