2009-04-17 04:03:47     svn trunk won't change to ^]mode char, strange behaviour

Document created by Aaronwu Employee on Aug 15, 2013
Version 1Show Document
  • View in full screen mode

2009-04-17 04:03:47     svn trunk won't change to ^]mode char, strange behaviour

Ralph Bertelsmann (GERMANY)

Message: 72771   

 

Hello everyone,

 

my freshly build uclinux-dist-trunk-svn-7972 for surveyor srv1 is behaving strange.

 

 

 

it boots up, but in the console i have the following issues:

 

- i can't change to mode char. i hit the escape character ^] an type mode char, nothing happens, new line.

 

- in telnet mode i type

 

telnet> status

Connected to 192.168.0.5.

Escape character is '^]'.

... nothing, i hit enter and i am back at:

 

#

 

- my login says #, not root:/

 

- on just hitting enter i get

 

#

 

# #

 

# #

 

sometimes even a "syntax error".

 

some infos:

 

# version

kernel:    Linux release 2.6.28.9-ADI-2009R1-pre, build #1 Thu Apr 16 10:05:25 CEST 2009

toolchain: bfin-uclinux-gcc release gcc-Version 4.1.2 (ADI svn)

user-dist: release 2008R1, build #1 Do 16. Apr 10:08:53 CEST 2009

 

 

 

i first did the make with the stock toolchain in ubuntu (via apt-get),

 

then i replaced it with

 

blackfin-toolchain-uclinux-SVN.i386.tar.bz2

 

blackfin-toolchain-linux-uclibc-SVN.i386.tar.bz2

 

from alpha.

 

 

 

I thought at least

 

user-dist: release 2008R1, build #2 Do 16. Apr 13:52:22 CEST 2009

 

would change after updating the toolchain, but it didn't.

 

(or is the user-dist output something else?)

 

 

 

i don't know what the problem is, any hints?

TranslateQuoteReplyEditDelete

 

 

2009-04-17 09:43:35     Re: svn trunk won't change to ^]mode char, strange behaviour

Ralph Bertelsmann (GERMANY)

Message: 72778   

 

Hmm my board uses a uart to wlan converter. (Matchport)

 

So my telnet login goes through dev/ttyBF0.

 

Maybe the serial settings have changed in Trunk?

 

 

 

Maybe tips in that direction?

TranslateQuoteReplyEditDelete

 

 

2009-04-17 09:51:08     Re: svn trunk won't change to ^]mode char, strange behaviour

Michael Hennerich (GERMANY)

Message: 72779    You mentioned in one of your previous emails that your prompt changed as

well.

I guess the whole issue is caused by copying your old user space config

into a recent uClinux-dist.

I bet you miss some busybox options etc.

 

-Michael

 

QuoteReplyEditDelete

 

 

2009-04-20 08:22:45     Re: svn trunk won't change to ^]mode char, strange behaviour

Ralph Bertelsmann (GERMANY)

Message: 72871   

 

Ok i have solved the problem.

 

Pretty easy, as always, if you know how it is done.

 

Just include:

 

- BusyBox -> Busybox Settings -> Busybox Library Tuning ->

-> Command line editing

-> vi-style line editing commands

-> Tab completion

-> Fancy shell prompts

 

and everything is fine.

 

 

 

JFYI!

Attachments

    Outcomes