2009-03-30 16:36:05     problem compiling ucLinux for BF561

Document created by Aaronwu Employee on Aug 14, 2013
Version 1Show Document
  • View in full screen mode

2009-03-30 16:36:05     problem compiling ucLinux for BF561

Vlad Maximoff (RUSSIAN FEDERATION)

Message: 71794   

 

Hi, should I take any additional steps to configure  uclinux for BF561EZKIT, because I got number of errors during compilation process, first one related to BusyBox, but when I disable it, other errors appear. I can still successfully compile uclinux, say to 537EZKIT.

 

Many thanks in advance.

QuoteReplyEditDelete

 

 

2009-03-30 16:41:19     Re: problem compiling ucLinux for BF561

Mike Frysinger (UNITED STATES)

Message: 71796   

 

BF561-EZKIT builds fine for me and has for quite a long time.  you'll have to provide real details if you want assistance.

 

what version of toolchain/uclinux-dist are you using ?  what are the exact commands you ran ?  what are the exact errors you saw ?

QuoteReplyEditDelete

 

 

2009-03-31 06:57:56     Re: problem compiling ucLinux for BF561

Vlad Maximoff (RUSSIAN FEDERATION)

Message: 71870   

 

Hello, Mike!

 

Compilation ends with following error:

 

LINK    busybox_unstripped

bfin-uclinux-strip: busybox_unstripped: File format not recognized

make[3]: Leaving directory `/home/vlad/uClinux-dist/user/busybox'

make[2]: Leaving directory `/home/vlad/uClinux-dist/user'

make[1]: *** [all] Error 2

make[1]: Leaving directory `/home/vlad/uClinux-dist/user'

make: *** [subdirs] Error 1

 

 

I got toolchain via repository: deb  download.analog.com/27516/distros/debian stable main

 

gcc version: 4.3.2 (Ubuntu 4.3.2-1ubuntu12)

 

uClinux version:  blackfin.uclinux.org/gf/download/frsrelease/401/5088/uClinux-dist-2008R1.5-RC3.tar.bz2

 

 

QuoteReplyEditDelete

 

 

2009-03-31 07:16:18     Re: problem compiling ucLinux for BF561

Mike Frysinger (UNITED STATES)

Message: 71872   

 

that is a warning, not an error.  you need to run `make NON_SMP_BUILD=1` to see the real error.

QuoteReplyEditDelete

 

 

2009-03-31 07:57:49     Re: problem compiling ucLinux for BF561

Vlad Maximoff (RUSSIAN FEDERATION)

Message: 71874   

 

Mike, thanks a lot! It is OK now

 

bfin-elf-gcc seems to be required on some stage of compilation, i was little bit misguided with that line of documentation:

 

"Since most people will be working with Linux, there is no need for them to even install the bfin-elf toolchain"

 

 

QuoteReplyEditDelete

 

 

2009-03-31 08:01:52     Re: problem compiling ucLinux for BF561

Mike Frysinger (UNITED STATES)

Message: 71875   

 

if you want to run code in Core B (and thus you enabled the core b examples), then you will need the elf compiler

QuoteReplyEditDelete

Attachments

    Outcomes