2009-03-30 09:50:31     Compiling uClinux

Document created by Aaronwu Employee on Aug 14, 2013
Version 1Show Document
  • View in full screen mode

2009-03-30 09:50:31     Compiling uClinux

Igor Leikakh (ISRAEL)

Message: 71779   

 

Getting error while compiling uClinux.

 

There is make output:

 

...

 

bfin-uclinux-gcc -DHAVE_CONFIG_H -I. -I../strace-4.5.18 -Ilinux/bfin -I../strace-4.5.18/linux/bfin -Ilinux -I../strace-4.5.18/linux  -DEMBED -D__uClinux__ -I/home/igor/uClinux-dist  -mcpu=bf527-0.1 -Wall -pipe -Wall -g -O2      -mcpu=bf527-0.1 -c ../strace-4.5.18/syscall.c

../strace-4.5.18/syscall.c: In function ‘get_scno’:

../strace-4.5.18/syscall.c:905: error: ‘PT_ORIG_P0’ undeclared (first use in this function)

...

 

Attached whole output of "make single" command.

 

Thank you for any help.

 

make_single_output2.txt

QuoteReplyEditDelete

 

 

2009-03-30 10:10:39     Re: Compiling uClinux

Robin Getz (UNITED STATES)

Message: 71780   

 

Igor:

 

this is normally caused by a missmatch between the kernel you build the toolchain against, and the version of the uClinux-dist you are compiling. It is defined in:

 

./trunk/uClinux-dist/linux-2.6.x/arch/blackfin/include/asm/ptrace.h:#define PT_ORIG_P0 212

 

and should be copied into here when the toolchain is built.

 

/trunk/gcc-4.1-uclinux/bfin-uclinux/runtime/usr/include/asm/ptrace.h:#define PT_ORIG_P0 212

 

Using an old toolchain on a new uClinux-dist isn't going to work - check the faq.

 

-Robin

QuoteReplyEditDelete

 

 

2009-03-30 10:20:28     Re: Compiling uClinux

Igor Leikakh (ISRAEL)

Message: 71781   

 

I'm using blackfin-toolchain-08r1.5-14.i386.

 

Is it too old for current svn uClinux trunk version?

QuoteReplyEditDelete

 

 

2009-03-30 15:45:57     Re: Compiling uClinux

Mike Frysinger (UNITED STATES)

Message: 71788   

 

svn trunk dist requires svn trunk toolchain

QuoteReplyEditDelete

 

 

2009-03-30 16:11:46     Re: Compiling uClinux

Robin Getz (UNITED STATES)

Message: 71791   

 

Igor:

 

Like I said - check the faq:

 

https://docs.blackfin.uclinux.org/doku.php?id=faq

 

Why do I need to use the same version of toolchain/kernel/uClibc/U-boot/uClinux-dist?

Attachments

Outcomes