2009-03-17 06:32:51     Help me: i can't boot my system

Document created by Aaronwu Employee on Aug 14, 2013
Version 1Show Document
  • View in full screen mode

2009-03-17 06:32:51     Help me: i can't boot my system

Emanuele Italia (ITALY)

Message: 71096   

 

Hello,

 

i was tring the vlan module but i found out freezing system when the vlan cable it's plugged.

 

I was using the tarball version 2007R1.1 so i decide to compile the vlan module from the branch and compile the modules-init-tools by myself for "force" insmod to put the vlan branch module in the tarball kernel(busybox doesn't work  force option).

 

After the "new" vlan module was loaded  for every input answer me modprobe!!

 

So when i try to boot my system...

 

 

 

dma_alloc_init: dma_page @ 0x00176000 - 256 pages at 0x03f00000

FATAL: Module /etc/rc not found.

init: Booting to single user mode

Usage: /bin/sh [-v] [-V] [-C config-file] [-n] [-i] [-q] [-b] [-o <modname>] [ --dump-modversions ] <m

odname> [parameters...]

/bin/sh -r [-n] [-i] [-v] <modulename> ...

/bin/sh -l -t <dirname> [ -a <modulename> ...]

v] <modulename> ...

/bin/sh -l -t <dirname> [ -a <modulename> ...]

Usage: -/bin/sh [-v] [-V] [-C config-file] [-n] [-i] [-q] [-b] [-o <modname>] [ --dump-modversions ] <

modname> [parameters...]

-/bin/sh -r [-n] [-i] [-v] <modulename> ...

-/bin/sh -l -t <dirname> [ -a <modulename> ...]

 

 

 

entering in U-Boot, i can boot in the filesystem...but i just see...a part of it...some files missing..some directory missing..

 

this is the row that i write in "U-Boot":

 

     setenv bootargs  init=/bin/sh

 

 

 

Can you help me? maybe some hints to go inside in the "true" filesystem and change the bad module.

 

 

 

Thank you in advance

 

 

 

Emanuele

 

 

 

P.S.

 

Sorry for my poor english and spammy subject

 

 

 

 

TranslateQuoteReplyEditDelete

 

 

2009-03-17 08:09:08     Re: Help me: i can't boot my system

Phil Wilshire (UNITED STATES)

Message: 71099   

 

HI Emanuele,

 

Go to a later release and get back to a working file system.

 

Trying to "force" and "bypass" things when so much work has been put into getting the basic system working

 

is NOT A GOOD IDEA and will not get much support here.

 

 

 

Get back to a working system and then try to add the vlan module. You'll get much more help that way.

 

 

 

regards

 

  Phil Wilshire

 

 

 

 

QuoteReplyEditDelete

 

 

2009-03-17 09:13:58     Re: Help me: i can't boot my system

Emanuele Italia (ITALY)

Message: 71107   

 

The problem is "how to get back".

 

Anyway it's very strange because the module that give me this kind of issue, it doesn't compare in the filesystem(when i boot with init=/bin/sh).

 

Regards,

 

 

 

Emanuele

 

 

TranslateQuoteReplyEditDelete

 

 

2009-03-17 09:22:49     Re: Help me: i can't boot my system

Emanuele Italia (ITALY)

Message: 71108   

 

I did  backup with "dd" on /dev/mtdblock2. is there some way to push that image on /dev/mtdblock2?

 

 

 

Thank you in advance

 

 

 

Emanuele

TranslateQuoteReplyEditDelete

 

 

2009-03-17 11:54:53     Re: Help me: i can't boot my system

Emanuele Italia (ITALY)

Message: 71119   

 

i resolved :|

Attachments

    Outcomes