2009-02-19 05:49:32     Epson S1D13513 Driver on 2008R1.5

Document created by Aaronwu Employee on Aug 14, 2013
Version 1Show Document
  • View in full screen mode

2009-02-19 05:49:32     Epson S1D13513 Driver on 2008R1.5

Michael Heiser (GERMANY)

Message: 69629   

 

Hi guys,

 

The last days the new Driver for the Epson S1D13513 LCD Controller Chip has released. I added the source into my uClinux-dist under /driver/video/epson and i modified the Kconfig and the Makefile to get Access to the Driver in Kernelconfig.

 

These steps went well. I can choose the Epson Driver in the Kernel Config and the make process does its job very good. The Driver is included in the Kernel.

 

So After booting my device i cant find any indicators whether the driver has been recognized. Theres no /dev/fb0 or any other file or folder.

 

Where can I find the new Framebuffer driver? And has anyone any experience in Adding this driver in uClinux?

 

Regards

 

Michael

TranslateQuoteReplyEditDelete

 

 

2009-02-19 05:52:44     Re: Epson S1D13513 Driver on 2008R1.5

Michael Heiser (GERMANY)

Message: 69630   

 

By the way the source of the Driver can be found here: vdc.epson.com/index.php

TranslateQuoteReplyEditDelete

 

 

2009-02-19 07:13:08     Re: Epson S1D13513 Driver on 2008R1.5

Michael Hennerich (GERMANY)

Message: 69634   

 

First of all make sure that the s1d13513fb_init(void) gets called during kernel start.

Try loading the driver as a module, too.

 

You should see some printks if something goes wrong later.

 

How did you connect the s1d13513 to Blackfin’s EBIU?

 

You certainly need to updated following defines – to match your memory map.

 

S1D_PHYSICAL_REG_ADDR

S1D_PHYSICAL_VMEM_ADDR

 

-Michael

 

QuoteReplyEditDelete

 

 

2009-02-19 07:33:14     Re: Epson S1D13513 Driver on 2008R1.5

Michael Heiser (GERMANY)

Message: 69635   

 

I just not connected the S1D13513 to my Board. This was only a test if the driver would be recongnized by the Kernel. But we want to connect the chip via the asynchronous memory bus to the Blackfin. After reading some topics here in the forum i recognized that the device has to be connected that the kernel creates a device like /def/fb0.

 

What do you think. Would it be possible to use the memory bus for S1D13513 in indirect parallel mode?

TranslateQuoteReplyEditDelete

 

 

2009-02-19 08:11:54     Re: Epson S1D13513 Driver on 2008R1.5

Michael Hennerich (GERMANY)

Message: 69636   

 

I would use direct parallel mode. Was only briefly looking over the spec.

But in case the video mem address space is also mapped indirect - it wouldn't be too useful for an typical Linux framebuffer.

 

If you are using Blackfin derivatives with 1MB address space per AMS, map the VMEM space into an different AMS block than the register space.

 

Also take a look here:

http://www.analog.com/static/imported-files/application_notes/59889364080788ee184.pdf#xml=http://search.analog.com/search/pdfPainter.aspx?url=http://www.analog.com/static/imported-files/application_notes/59889364080788ee184.pdf&fterm=s1d13806&fterm=s1d13806&la=en

 

The S1D13806 is quite similar in terms of the host interface.

 

-Michael

 

QuoteReplyEditDelete

 

 

2009-02-19 08:13:50     Re: Epson S1D13513 Driver on 2008R1.5

Michael Hennerich (GERMANY)

Message: 69637   

 

By the way … If you only like to interface a small QVGA or WQVGA TFT display to Blackfin –

You can connect it directly without using an external graphics controller…

 

 

-Michael

 

QuoteReplyEditDelete

 

 

2009-02-19 09:50:44     Re: Epson S1D13513 Driver on 2008R1.5

Michael Heiser (GERMANY)

Message: 69638   

 

Infact we want to use a Display with 800x480 and 16bit Colordepth and later we want to use the Camera Interface of the Epson Chip.

 

Thank you!

 

-Michael

TranslateQuoteReplyEditDelete

 

 

2009-03-02 09:48:36     Re: Epson S1D13513 Driver on 2008R1.5

Michael Heiser (GERMANY)

Message: 70223   

 

Hey guys,

 

Another question to this topic. I just connected the epson-DevBoard to to my Bluetechnix-DevKit. I used AMS for the connection but I have to use the Indirect Mode of the Epson chip. Then i compiled the driver as a module. That went well. After booting uClinux I can't find the module in uClinux.

 

So where can I find the driver-module?

 

Regards,

 

Michael

Attachments

    Outcomes