2009-02-13 07:45:57     Konqueror Embedded problems with kresolver.cpp

Document created by Aaronwu Employee on Aug 13, 2013
Version 1Show Document
  • View in full screen mode

2009-02-13 07:45:57     Konqueror Embedded problems with kresolver.cpp

Patrick Hotz (GERMANY)

Message: 69414   

 

Hi Guys,

 

new thread, new problem... ;-)

 

I try to compile the Konqueror Embedded with uClinux-dist2008R1.5.

I use the instructions from  docs.blackfin.uclinux.org/doku.php?id=uclinux-dist:konqueror and followed the build exactly.

The qt-embedded 3.3.5 is build with FLAT static binary ( docs.blackfin.uclinux.org/doku.php?id=uclinux-dist:qt&rev=1213628771) and the konqueror i want to build is also FLAT static binary....

 

Thats what i have done:

applyed the patch... OK

configured to FLAT static binary.... OK

make.... ERROR

 

.......

In file included from ../../../../konq-embed/dropin/kapplication.h:43,

                 from ../../../../konq-embed/dropin/kglobal.h:27,

                 from ../../../../konq-embed/dropin/klocale.h:31,

                 from kresolver.cpp:57:

../../../../konq-embed/kdesrc/kdecore/kdeversion.h:25:1: warning: this is the location of the previous definition

kresolver.cpp:65:2: warning: #warning "mutex"

kresolver.cpp: In static member function 'static int KNetwork::KResolver::servicePort(const char*, const char*)':

kresolver.cpp:777: error: invalid 'asm': invalid operand for code 'w'

make[6]: *** [kresolver.lo] Fehler 1

make[6]: Leaving directory `/home/patrick/Konqueror-Embedded/konqueror3-embedded-0.2-20060121/konq-embed/kdesrc/kdecore/network'

make[5]: *** [all-recursive] Fehler 1

make[5]: Leaving directory `/home/patrick/Konqueror-Embedded/konqueror3-embedded-0.2-20060121/konq-embed/kdesrc/kdecore'

make[4]: *** [all] Fehler 2

make[4]: Leaving directory `/home/patrick/Konqueror-Embedded/konqueror3-embedded-0.2-20060121/konq-embed/kdesrc/kdecore'

make[3]: *** [all-recursive] Fehler 1

make[3]: Leaving directory `/home/patrick/Konqueror-Embedded/konqueror3-embedded-0.2-20060121/konq-embed/kdesrc'

make[2]: *** [all-recursive] Fehler 1

make[2]: Leaving directory `/home/patrick/Konqueror-Embedded/konqueror3-embedded-0.2-20060121/konq-embed'

make[1]: *** [all-recursive] Fehler 1

make[1]: Leaving directory `/home/patrick/Konqueror-Embedded/konqueror3-embedded-0.2-20060121'

make: *** [all] Fehler 2

patrick@P-Linux:~/Konqueror-Embedded/konqueror3-embedded-0.2-20060121$

 

 

 

Does anyone have an idea how i can solve this problem??

 

Best Regards,

Patrick

Attachments

    Outcomes