2009-01-27 03:25:19     Kernel stops after "Starting Kernel at = 1ad504"

Document created by Aaronwu Employee on Aug 9, 2013
Version 1Show Document
  • View in full screen mode

2009-01-27 03:25:19     Kernel stops after "Starting Kernel at = 1ad504"

Patrick Hotz (GERMANY)

Message: 68374   

 

Hi guys,

 

after i have successful changed my system to a "no ramdisk" system i have a little problem during bootup...

My kernel in flash is the "vmImage" and the rootfilesystem is "rootfs.jffs2"

 

If i connect the power-supply to my board the kernel stops booting at "Starting Kernel at = 1ad504"

I have tried to read the Kernel log but the output i get is not very usefull for me.

 

TCM-BF537> md.b 1874d0

001874d0: 3c 35 3e 4c 69 6e 75 78 20 76 65 72 73 69 6f 6e    <5>Linux version

001874e0: 20 32 2e 36 2e 32 38 2d 41 44 49 2d 32 30 30 39     2.6.28-ADI-2009

001874f0: 52 31 2d 70 72 65 2d 73 76 6e 36 30 31 34 20 28    R1-pre-svn6014 (

00187500: 70 68 6f 74 7a 40 48 57 45 4c 69 6e 75 78 29 20    photz@HWELinux)

TCM-BF537> md.b 187510

00187510: 28 67 63 63 20 76 65 72 73 69 6f 6e 20 34 2e 31    (gcc version 4.1

00187520: 2e 32 20 28 41 44 49 20 73 76 6e 29 29 20 23 31    .2 (ADI svn)) #1

00187530: 31 32 20 4d 6f 6e 20 4a 61 6e 20 32 36 20 31 35    12 Mon Jan 26 15

00187540: 3a 35 33 3a 34 37 20 43 45 54 20 32 30 30 39 0a    :53:47 CET 2009.

TCM-BF537> md.b 187550

00187550: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................

00187560: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................

00187570: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................

00187580: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00    ................

.......

 

The curious thing is this:

If i load "uImage.ext2" onto my ram at 0x1000000 and run "bootm 1000000" the system starts ok.....

Then i remove the power supply for a short time and reconnect it afterwards, and the kernel (vmImage on flash) boots ok.

 

I am very confused about this....

 

 

 

- Patrick

TranslateQuoteReplyEditDelete

 

 

2009-01-27 16:43:19     Re: Kernel stops after "Starting Kernel at = 1ad504"

Mike Frysinger (UNITED STATES)

Message: 68439   

 

can you hook up jtag to find out where things have hung up ?

QuoteReplyEditDelete

 

 

2009-01-28 01:47:45     Re: Kernel stops after "Starting Kernel at = 1ad504"

Patrick Hotz (GERMANY)

Message: 68447   

 

Thats a little problem for me, i haven´t a jtag-device.....

I use "boot from uart" for first loading u-boot on my system......

 

Can you have a look to see whats wrong?

 

- Patrick

TranslateQuoteReplyEditDelete

 

 

2009-08-02 09:13:40     Re: Kernel stops after "Starting Kernel at = 1ad504"

Peter Tawdross (GERMANY)

Message: 78272   

 

i got the same problem, did you find the reason?

QuoteReplyEditDelete

 

 

2009-08-02 20:11:54     Re: Kernel stops after "Starting Kernel at = 1ad504"

Robin Getz (UNITED STATES)

Message: 78274   

 

Peter:

 

Alot has changed in 8 months - if might be best to start a new thread.

 

-Robin

Attachments

    Outcomes