2009-01-22 07:54:28     error while building kenel in Eclipse

Document created by Aaronwu Employee on Aug 9, 2013
Version 1Show Document
  • View in full screen mode

2009-01-22 07:54:28     error while building kenel in Eclipse

Kaustubh Vaidya (INDIA)

Message: 68232   

 

Hi ;

 

While building kenel with user created application in Eclipse it gives following error message in console of Eclipse

 

/usr/bin/make -j /home/kvvaidya/eclipse/../prop /home/kvvaidya/eclipse/../vendors///. blkfin-apps blkfin-drvs blkfin-test games || exit $?

make[1]: Entering directory `/home/kvvaidya/uClinux-dist/user'

[ ! -d "/home/kvvaidya/eclipse/../prop" ] || ( touch /home/kvvaidya/eclipse/../prop/.sgbuilt_user && /usr/bin/make -j1 -C /home/kvvaidya/eclipse/../prop ) || exit $?

make[1]: Leaving directory `/home/kvvaidya/uClinux-dist/user'

make[1]: *** No rule to make target `/home/kvvaidya/eclipse/../vendors///.'.  Stop.

make[1]: *** Waiting for unfinished jobs....

make: *** [all] Error 2

 

But if I tried same on terminal using menuconfig command it creates image of kernel .

 

So please guide me regarding this...

 

Thank You....................

QuoteReplyEditDelete

 

 

2009-01-22 09:36:21     Re: error while building kenel in Eclipse

Mike Frysinger (UNITED STATES)

Message: 68236   

 

looks like you havent properly configured the dist yet.  the multiple slashes indciates incomplete configuration (vendor/board selection).

QuoteReplyEditDelete

 

 

2009-01-22 09:50:51     Re: error while building kenel in Eclipse

Kaustubh Vaidya (INDIA)

Message: 68238   

 

So what should I do  for that?

 

because while working on terminal it creates images without problem.

QuoteReplyEditDelete

 

 

2009-01-22 10:13:38     Re: error while building kenel in Eclipse

Mike Frysinger (UNITED STATES)

Message: 68242   

 

configure your dist like normal using the menuconfig system

QuoteReplyEditDelete

 

 

2009-01-22 22:45:12     Re: error while building kenel in Eclipse

Kaustubh Vaidya (INDIA)

Message: 68256   

 

Ok that means for building kernel I must use terminal rather than eclipse ?

QuoteReplyEditDelete

 

 

2009-01-22 22:51:03     Re: error while building kenel in Eclipse

Mike Frysinger (UNITED STATES)

Message: 68257   

 

there are gui alternatives to the ncurses based menuconfig.  like xconfig.

QuoteReplyEditDelete

 

 

2009-01-22 22:59:40     Re: error while building kenel in Eclipse

Kaustubh Vaidya (INDIA)

Message: 68259   

 

So as given in eclipse documentation , we are executing xconfig ,make, dep commands from eclipse rather than bash.So is it possible to run menuconfig command through eclipse by following same procedure like xconfig?

QuoteReplyEditDelete

 

 

2009-01-22 23:07:53     Re: error while building kenel in Eclipse

Mike Frysinger (UNITED STATES)

Message: 68260   

 

if xconfig is run properly, it should do the same thing as menuconfig

QuoteReplyEditDelete

 

 

2009-01-22 23:24:05     Re: error while building kenel in Eclipse

Kaustubh Vaidya (INDIA)

Message: 68262   

 

ok then I will try using menuconfig in eclipse .

 

 

QuoteReplyEditDelete

 

 

2009-01-23 00:28:29     Re: error while building kenel in Eclipse

Kaustubh Vaidya (INDIA)

Message: 68263   

 

I tried using menuconfig in eclipse but it gave me garbage value so I again tried with the xconfig this time it started compiling it first showed me vendor selection window after saving changes it gives me message unable to find Qt installation but iI have installed Qt 4.4.3 after that without showing further windows it started compiling the kernel & created the image file.

 

So what is getting wrong  why it is showing Qt not installed message?

 

Thank You..................

QuoteReplyEditDelete

 

 

2009-01-23 11:45:04     Re: error while building kenel in Eclipse

Mike Frysinger (UNITED STATES)

Message: 68298   

 

probably because you dont have QT installed.  you could try the GTK target instead (gconfig), although i dont recall if this was supported in the 2008R1.5 release ... it's certainly in svn trunk.

QuoteReplyEditDelete

 

 

2009-01-24 07:50:51     Re: error while building kenel in Eclipse

Kaustubh Vaidya (INDIA)

Message: 68333   

 

I am not using QT embedded linux version .Is this a reason for this problem?

QuoteReplyEditDelete

 

 

2009-01-24 09:41:15     Re: error while building kenel in Eclipse

Mike Frysinger (UNITED STATES)

Message: 68334   

 

no one is talking about QT embedded.  the gui is written in QT so if you want to use it, install QT on your system.

Attachments

    Outcomes