2009-01-04 04:45:13     No /dev/sda in bf527 ezkit

Document created by Aaronwu Employee on Aug 9, 2013
Version 1Show Document
  • View in full screen mode

2009-01-04 04:45:13     No /dev/sda in bf527 ezkit

Bill Xie (CHINA)

Message: 67328   

 

My uClinx is uClinux-dist-2008R1-RC8 . It is not found /dev/sda.Does udev is not mount this node?

 

dmsg:

 

   SCSI subsystem initialized

usbcore: registered new interface driver usbfs

usbcore: registered new interface driver hub

usbcore: registered new device driver usb

musb_hdrc: version 6.0, pio, host, debug=0

musb_hdrc: ConfigData=0x00 (UTMI-8)

musb_hdrc: hw_ep 0shared, max 64

musb_hdrc: hw_ep 1tx, max 128

musb_hdrc: hw_ep 1rx, max 128

musb_hdrc: hw_ep 2tx, max 128

musb_hdrc: hw_ep 2rx, max 128

musb_hdrc: hw_ep 3tx, max 128

musb_hdrc: hw_ep 3rx, max 128

musb_hdrc: hw_ep 4tx, max 128

musb_hdrc: hw_ep 4rx, max 128

musb_hdrc: hw_ep 5tx, max 1024

musb_hdrc: hw_ep 5rx, max 1024

musb_hdrc: hw_ep 6tx, max 1024

musb_hdrc: hw_ep 6rx, max 1024

musb_hdrc: hw_ep 7tx, max 1024

musb_hdrc: hw_ep 7rx, max 1024

musb_hdrc: USB Host mode controller at ffc03800 using PIO, IRQ 59

musb_hdrc musb_hdrc.0: MUSB HDRC host driver

drivers/usb/core/inode.c: creating file 'devices'

drivers/usb/core/inode.c: creating file '001'

musb_hdrc musb_hdrc.0: new USB bus registered, assigned bus number 1

usb usb1: default language 0x0409

usb usb1: new device strings: Mfr=3, Product=2, SerialNumber=1

usb usb1: Product: MUSB HDRC host driver

usb usb1: Manufacturer: Linux 2.6.22.18-ADI-2008R1-svn musb-hcd

usb usb1: SerialNumber: musb_hdrc.0

usb usb1: uevent

usb usb1: usb_probe_device

usb usb1: configuration #1 chosen from 1 choice

usb usb1: adding 1-0:1.0 (config #1, interface 0)

usb 1-0:1.0: uevent

usb 1-0:1.0: uevent

hub 1-0:1.0: usb_probe_interface

hub 1-0:1.0: usb_probe_interface - got id

hub 1-0:1.0: USB hub found

hub 1-0:1.0: 1 port detected

hub 1-0:1.0: standalone hub

hub 1-0:1.0: individual port power switching

hub 1-0:1.0: no over-current protection

hub 1-0:1.0: Single TT

hub 1-0:1.0: TT requires at most 8 FS bit times (666 ns)

hub 1-0:1.0: power on to power good time: 10ms

hub 1-0:1.0: local power source is good

hub 1-0:1.0: enabling power on all ports

hub 1-0:1.0: state 7 ports 1 chg 0000 evt 0000

drivers/usb/core/inode.c: creating file '001'

 

 

QuoteReplyEditDelete

 

 

2009-01-04 07:34:24     Re: No /dev/sda in bf527 ezkit

Mike Frysinger (UNITED STATES)

Message: 67329   

 

udev isnt used by default, mdev is.  however, that doesnt matter if the kernel isnt finding the device.  in this case, no disk was found, so there is no sda to create.

 

that output indicates the device has a hub in it ... that wont work as usb hubs are not supported

QuoteReplyEditDelete

 

 

2009-01-04 23:58:36     Re: No /dev/sda in bf527 ezkit

Bill Xie (CHINA)

Message: 67346   

 

Mike:

 

    Thank you for response.But how to solve this problem?

 

 

 

  Bill

QuoteReplyEditDelete

 

 

2009-01-05 00:07:16     Re: No /dev/sda in bf527 ezkit

Mike Frysinger (UNITED STATES)

Message: 67347   

 

if hubs arent supported, then dont use one

QuoteReplyEditDelete

 

 

2009-01-05 02:01:23     Re: No /dev/sda in bf527 ezkit

Bill Xie (CHINA)

Message: 67349   

 

  How to config this mode?Thank you.

QuoteReplyEditDelete

 

 

2009-01-05 07:50:02     Re: No /dev/sda in bf527 ezkit

Robin Getz (UNITED STATES)

Message: 67380   

 

Bill:

 

What Mike means is that USB hubs are not supported by the hardware - there is nothing to change in the software.

 

The only option you have is not to use a USB hub between the Blackfin and the device you want it connected to. If there is direct connection - things will work. If there is a hub inbetween - the USB controller inside the Blackfin does not support it.

 

If your USB device has a built in hub (like many do) - there is no way that that device will work with a Blackfin.

 

-Robin

QuoteReplyEditDelete

 

 

2009-01-05 20:21:01     Re: No /dev/sda in bf527 ezkit

Bill Xie (CHINA)

Message: 67397   

 

Robin:

 

     Thank you for your response.It is not using usb hub in my test.I use SanDisk 1G cruzer direct connection by usb cable

 

to bf527 ezkit usb otg .

 

Bill

QuoteReplyEditDelete

 

 

2009-01-05 21:59:58     Re: No /dev/sda in bf527 ezkit

Robin Getz (UNITED STATES)

Message: 67405   

 

Bill:

 

What does lsusb -t show?

 

-Robin

QuoteReplyEditDelete

 

 

2009-01-05 23:46:18     Re: No /dev/sda in bf527 ezkit

Bill Xie (CHINA)

Message: 67408   

 

Robin:

 

      Thank you.Connected or not connected 1G Sandisk flash cruzer both display this message.

 

      root:/> lsusb -t

         Bus#  1

       `-Dev#   1 Vendor 0x1d6b Product 0x0002

 

--Bill

Attachments

    Outcomes