2008-12-15 06:48:47     Framebuffer and DirectFB on BF527 EZKIT

Document created by Aaronwu Employee on Aug 9, 2013
Version 1Show Document
  • View in full screen mode

2008-12-15 06:48:47     Framebuffer and DirectFB on BF527 EZKIT

Nikolay Chokoev (IRELAND)

Message: 66712   

 

Hi,

 

I'm configuring the uClinux according the document:

 

http://docs.blackfin.uclinux.org/doku.php?id=the_framebuffer_console

 

,but cannot see console on framebuffer running. The screen remains black.

 

When I try to run any of the directFB examples I've got:

 

(*) DirectFB/Core: Single Application Core. (2008-12-12 16:11)

DirectFB/core/system: No system found!

../../DirectFB-examples-1.0.1/src/df_window.c <88>:

        (#) DirectFBError [DirectFBCreate( &dfb )]: No (suitable) implementation

found!

 

 

 

I'm sure I'm doing something wrong, or something missing, but what is it?

 

Best regards,

 

Nikolay

QuoteReplyEditDelete

 

 

2008-12-15 13:16:58     Re: Framebuffer and DirectFB on BF527 EZKIT

Mike Frysinger (UNITED STATES)

Message: 66720   

 

there isnt much point in trying to run DirectFB if your framebuffer isnt setup properly

 

did you enable all the kernel options that page documented ?  what hardware exactly are you using ?

QuoteReplyEditDelete

 

 

2008-12-15 14:34:41     Re: Framebuffer and DirectFB on BF527 EZKIT

Nikolay Chokoev (IRELAND)

Message: 66726   

 

Hi Mike,

 

Thanks for the reply.

 

I do everything like it is described on the site, but cannot see the console on the LCD framebuffer yet. The video demo works fine. If I I do echo something > /dev/fb0, the screen blinks, so I suppose I have something working...

 

The hardware is BF527-EZKIT.

 

Now I try to build Qt, and hopefully will try it tomorrow.

 

Regards,

 

Nikolay

Attachments

    Outcomes