2008-12-03 03:54:49     MMC/SD card mounting problem

Document created by Aaronwu Employee on Aug 8, 2013
Version 1Show Document
  • View in full screen mode

2008-12-03 03:54:49     MMC/SD card mounting problem

P SENTHIL KUMAR (INDIA)

Message: 66196   

 

Dear all,

 

             I am using 2008R1.5 release versions and BF561 based custom board.

 

Our custom board have a connectivity for SD card thourgh blackfin SPI directly.

 

I  had done configuration for SD card detection in 2008R1.5 release and got the below mount issues

 

root:/> cat /proc/spi_mmc

Driver build date: Dec  2 2008

SCLK: 20000 KHz

SPISEL2 as chip select

Driver: Blackfin PIO SPI directly

Total errors: 0

 

SD card :

         Capacity: 30605312 B

         Name: SD032X

         Rev: 0.0

         Date: 2008/5

         Serial: 0xef8e65 (15699557)

         CSD ver.: 0

         CCC supported: 1f5

         Mult. block writes works: YES

last block:      0

users:   0

Performance for last 100 transfers

         Mean read throughput:   38 kB/s

         Mean write throughput:  152 kB/s

 

root:/> mkfs.vfat /dev/spi_mmc

mkfs.vfat 2.10 (22 Sep 2003)

root:/> mount -t vfat -o sync /dev/spi_mmc /mnt

FAT: IO charset iso8859-1 not found

mount: mounting /dev/spi_mmc on /mnt failed

 

Let me know how resolve the above issue

 

 

 

 

 

 

QuoteReplyEditDelete

 

 

2008-12-03 04:16:33     Re: MMC/SD card mounting problem

Yi Li (CHINA)

Message: 66203   

 

Please read: http://docs.blackfin.uclinux.org/doku.php?id=linux-kernel:drivers:spi_mmc

 

You need to enable native language support.

 

-Yi

QuoteReplyEditDelete

 

 

2008-12-03 04:36:34     Re: MMC/SD card mounting problem

P SENTHIL KUMAR (INDIA)

Message: 66221   

 

Hi Yi,

 

         Thanks for your reply,

 

I had enabled the native language support.

 

Regards, Senthil

 

 

QuoteReplyEditDelete

 

 

2008-12-03 07:55:30     Re: MMC/SD card mounting problem

P SENTHIL KUMAR (INDIA)

Message: 66234   

 

Hi YI,

 

         I had done the configuration as per the document path you had mentioned.

 

Evenafter doing the configurations, i am getting the same issue.

 

Regards,Senthil

QuoteReplyEditDelete

 

 

2008-12-03 08:09:18     Re: MMC/SD card mounting problem

Ian Jeffray (UNITED KINGDOM)

Message: 66236   

 

Are you sure you have

 

CONFIG_NLS_ISO8859_1=y

 

QuoteReplyEditDelete

 

 

2008-12-03 08:38:33     Re: MMC/SD card mounting problem

P SENTHIL KUMAR (INDIA)

Message: 66239   

 

Hi Ian,

 

Thanks for your reply.

 

In my .congig, i have not seen the option you mentioned.

 

but below is the .config file details i have got at the native languague support option.

 

#

# Native Language Support

#

CONFIG_NLS=y

CONFIG_NLS_DEFAULT="iso8859-1"

CONFIG_NLS_CODEPAGE_437=y

# CONFIG_NLS_CODEPAGE_737 is not set

# CONFIG_NLS_CODEPAGE_775 is not set

# CONFIG_NLS_CODEPAGE_850 is not set

 

 

Regards, Senthil

 

 

 

 

 

 

QuoteReplyEditDelete

 

 

2008-12-03 08:58:21     Re: MMC/SD card mounting problem

P SENTHIL KUMAR (INDIA)

Message: 66240   

 

HI Ian,

 

Let me know, where i can search the CONFIG_NLS_ISO8859_1=y option.

 

How i can enable the CONFIG_NLS_ISO8859_1=y option

 

Regards, Senthil

QuoteReplyEditDelete

 

 

2008-12-03 09:36:20     Re: MMC/SD card mounting problem

P SENTHIL KUMAR (INDIA)

Message: 66241   

 

Hi Ian Jeffray,

 

Thansk for your valuable support.

 

After enabling the option CONFIG_NLS_ISO8859_1,

 

i can able to mount the vfat and able to see the files from sdcard at mnt folder.

 

Once again thank you very much for the support.

 

Regards, Senthil

QuoteReplyEditDelete

 

 

2008-12-03 10:23:55     Re: MMC/SD card mounting problem

Ian Jeffray (UNITED KINGDOM)

Message: 66244   

 

Glad that worked.  I think it's a small oversight on the Wiki page -- it shows enabling ISO8859-1 as the default NLS language, but only shows enabling of CP437 as an available language.   I'm not sure who has the ability to fix the Wiki though.

QuoteReplyEditDelete

 

 

2008-12-03 15:46:45     Re: MMC/SD card mounting problem

Mike Frysinger (UNITED STATES)

Message: 66253   

 

the exact NLS needed depends on the files that are on the disk ... should make a dedicated page for this information

Attachments

    Outcomes