2008-10-19 04:52:38     BUG: soft lockup detected on CPU#0!

Document created by Aaronwu Employee on Aug 8, 2013
Version 1Show Document
  • View in full screen mode

2008-10-19 04:52:38     BUG: soft lockup detected on CPU#0!

w w (CHINA)

Message: 63910   

 

hi, all

 

I am using BF532, 16M SDRAM and 4M nor flash on my board.

 

I used uClinux2006R2-RC2, when I access my fxs board, the err is:

 

 

 

BUG: soft lockup detected on CPU#0!

 

PC: 02490408  Status: 0097  SysStatus: 0000  RETS: 02490718

A0.x: 00000000  A0.w: 00000000  A1.x: 00000000  A1.w: 00000000

P0: 0000000a  P1: 0012aba0  P2: ffc00508  P3: 00260000

P4: ffc0050c  P5: ffc00504

R0: 00000011  R1: 00000000  R2: 00000000  R3: 00000000

R4: 00000000  R5: 00000034  R6: 0000f718  R7: 0000ff18

 

before the bug occured, I can telnet the board,  but after the bug occured, I can ping the board only,  but I can not telnet it.

 

can you help me ? thank you !

QuoteReplyEditDelete

 

 

2008-10-19 05:09:48     Re: BUG: soft lockup detected on CPU#0!

Mike Frysinger (UNITED STATES)

Message: 63911   

 

make sure your driver isnt doing too much work in atomic context ... look at the code that is running where that small trace points you to

 

QuoteReplyEditDelete

 

 

2008-10-19 20:42:00     Re: BUG: soft lockup detected on CPU#0!

w w (CHINA)

Message: 63915   

 

my driver access a register on my fxs board only.  Some times the err occured, some times no. I think  there are something wrong about my uClinux kernel, but I don't know where.

Attachments

    Outcomes