2008-08-07 13:12:47     Cannot display on external LCD without ATAPI enabled (BF54x)

Document created by Aaronwu Employee on Aug 8, 2013
Version 1Show Document
  • View in full screen mode

2008-08-07 13:12:47     Cannot display on external LCD without ATAPI enabled (BF54x)

Isaac Leung (CANADA)

Message: 60110   

 

We are using a custom board with Blackfin BF547 actually and have a working uClinux which can boot via a serial console. The custom board uses the same LCD display and supporting components as the BF548 EZ-Kit so there ought to be no problem getting this working.

 

However, we are finding that the attached LCD screen will NOT display unless I configure the ATAPI support (Device Drivers->Serial ATA (prod) and Parallel ATA (experimental) drivers->Blackfin 54x ATAPI support). I've tried a kernel which otherwise boots to the console and ONLY toggled this option on / off and this will enable or disable output to the attached LCD display.

 

This doesn't make a whole lot of sense to us from hardware standpoint as we do not use ATAPI and the GPIO pins which would have been used for this are not attached to any display related signals. We can actually turn on the backlight and display prior to booting uClinux and it stays on during boot, so it looks like it's just that the frame buffer is not pointed there, not that some power or data signals are accidentally crossed in hardware.

 

Any tips or suggestions where to start looking to figure this out? At this point it's merely a minor annoyance making a bigger kernel image than we need.

 

(This wouldn't be the first thing like this, right now in order to get uClinux booting to serial console on UART3, we have to enable UART0 as well, even though we do not use UART0).

 

 

 

Thanks,

 

Isaac

QuoteReplyEditDelete

 

 

2008-08-07 14:04:49     Re: Cannot display on external LCD without ATAPI enabled (BF54x)

Robin Getz (UNITED STATES)

Message: 60115   

 

Issac:

 

Do you see the same thing on an EZKit?

 

-Robin

QuoteReplyEditDelete

 

 

2008-08-08 10:55:47     Re: Cannot display on external LCD without ATAPI enabled (BF54x)

Mike Frysinger (UNITED STATES)

Message: 60175   

 

the UART issue has already been fixed in the latest trees ... it was broken in the 2008R1 release

QuoteReplyEditDelete

 

 

2008-08-11 20:41:00     Re: Cannot display on external LCD without ATAPI enabled (BF54x)

Isaac Leung (CANADA)

Message: 60263   

 

I updated to latest 2008R1 from SVN (as of Aug.11, 2008). For the BF548 EZ-Kit, I can still see the boot messages & logo when the ATAPI driver is not installed. For our custom board, I cannot see anything on the LCD.

 

Funny issue, when ATAPI driver is enabled for our custom board, I can see the boot messages & logo and furthermore, when it is booted, /dev/tty0 does NOT exist. (I had to add "console=tty0" on the kernel boot parameters to get the boot messages to show on the LCD). However, with ATAPI driver disabled/removed, after booting, /dev/tty0 exists. However, sending anything to here doesn't show up on the LCD screen. The included simple video tests do work though.

 

It is not a real big issue yet as I can get at the device using serial console for now, but in the future, the LCD will be the one and only console. Any pointers where I can start looking for the issue?

 

 

 

Thanks,

 

Isaac

Attachments

    Outcomes