2008-10-03 11:45:32     Lost all custom uClinux settings on reset

Document created by Aaronwu Employee on Aug 7, 2013
Version 1Show Document
  • View in full screen mode

2008-10-03 11:45:32     Lost all custom uClinux settings on reset

John Redford (UNITED KINGDOM)

Message: 63096   

 

Hi, I am using the BF561 EZ KIT LITE evaluation board.

 

After a few days struggling to get uboot to work (and later finding out it was an incorrect serial cable!) I now have uboot sat in Flash memory ready to boot when the board is switched on. Then uClinux, which is also sat in Flash memory, is automatically run. Everything works just fine...

 

I spent a couple of hours customising settings in uClinux, and I setup boa webserver amongst other things. I expected that uClinux was automatically updating the file system to save my 'settings', however upon reset, everything has gone back to the default uClinux image

 

This is highly frustrating, so I'm sure there must be a way to enable settings to remain after reset?

 

Any information on this matter would be greatly appreciated,

 

 

 

Thanks in advance,

 

 

 

John Redford.

QuoteReplyEditDelete

 

 

2008-10-03 13:44:30     Re: Lost all custom uClinux settings on reset

Mike Frysinger (UNITED STATES)

Message: 63097   

 

by default, everything executes out of RAM.  there is no persitent storage.  if you want that, you need to use a persitent filesystem like jffs2 out of flash.

QuoteReplyEditDelete

 

 

2008-10-06 10:42:41     Re: Lost all custom uClinux settings on reset

John Redford (UNITED KINGDOM)

Message: 63162   

 

Hi, I was under the impression I am already using a jffs2 filesystem, since uClinux is loaded into flash and automatically boots everytime the board is reset. I thought that making changes in uClinux would then cause the relevant areas of the flash to be updated.

 

 

 

Is this not true?

 

Thanks in advance,

 

John Redford.

QuoteReplyEditDelete

 

 

2008-10-06 14:03:19     Re: Lost all custom uClinux settings on reset

Mike Frysinger (UNITED STATES)

Message: 63165   

 

no, that is not what is going on.  try reading this page and see if it clears things up:

http://docs.blackfin.uclinux.org/doku.php?id=uclinux-dist:images

Attachments

    Outcomes