2008-09-25 12:01:56     Problem building uImage with eclipse

Document created by Aaronwu Employee on Aug 7, 2013
Version 1Show Document
  • View in full screen mode

2008-09-25 12:01:56     Problem building uImage with eclipse

ivan ucles (GERMANY)

Message: 62718   

 

Hi,

 

i successfully compiled the kernel from bash following the steps described in the blackfin webpage (make menuconfig, make)

 

Now i'm trying to do the same with eclipse in order to add my own application. I followed the steps (configuring the external tools make xconfig etc.)

 

When i build the project i can select my own program in the xconfig menu.

 

But in the make proccess i get the error:

 

...

 

AR procps/lib.a

  AR shell/lib.a

  AR util-linux/lib.a

  LINK busybox_unstripped

make[3]: Leaving directory `/home/ivan/uClinux-dist-2008R1.5-RC3/user/busybox'

make[1]: *** [all] Error 2

make: *** [subdirs] Error 1

make[2]: Leaving directory `/home/ivan/uClinux-dist-2008R1.5-RC3/user'

make[1]: Leaving directory `/home/ivan/uClinux-dist-2008R1.5-RC3/user'

 

Could anyone give a hint of what is going wrong and how could i solve it?

 

 

Thanks.

 

 

 

 

QuoteReplyEditDelete

 

 

2008-09-25 14:36:45     Re: Problem building uImage with eclipse

Mike Frysinger (UNITED STATES)

Message: 62721   

 

that doesnt contain the actual error.  you need to look at the whole log.

 

QuoteReplyEditDelete

 

 

2008-09-29 06:06:45     Re: Problem building uImage with eclipse

ivan ucles (GERMANY)

Message: 62887   

 

Now i get a different error. Here is the end of the log file. What could be the error?

 

Where should i look in the rest of the log file to locate the error?

 

 

 

*

* System Logging Utilities

*

syslogd (SYSLOGD) [N/y/?] n

logger (LOGGER) [N/y/?] n

*

* Runit Utilities

*

runsv (RUNSV) [N/y/?] n

runsvdir (RUNSVDIR) [N/y/?] n

sv (SV) [N/y/?] n

svlogd (SVLOGD) [N/y/?] n

chpst (CHPST) [N/y/?] n

setuidgid (SETUIDGID) [N/y/?] n

envuidgid (ENVUIDGID) [N/y/?] n

envdir (ENVDIR) [N/y/?] n

softlimit (SOFTLIMIT) [N/y/?] n

yes: standard output: Broken pipe

yes: write error

make[3]: Leaving directory `/home/ivan/uClinux-dist-2008R1.5-RC3/user/busybox'

make[3]: make[3]: Entering directory `/home/ivan/uClinux-dist-2008R1.5-RC3/user/busybox'

warning: -jN forced in submake: disabling jobserver mode.

  SPLIT include/autoconf.h -> include/config/*

  GEN include/bbconfigopts.h

make[3]: Leaving directory `/home/ivan/uClinux-dist-2008R1.5-RC3/user/busybox'

make[1]: *** [all] Error 2

make[2]: Leaving directory `/home/ivan/uClinux-dist-2008R1.5-RC3/user'

make[1]: Leaving directory `/home/ivan/uClinux-dist-2008R1.5-RC3/user'

make: *** [subdirs] Error 1

 

 

QuoteReplyEditDelete

 

 

2008-09-29 14:48:38     Re: Problem building uImage with eclipse

Mike Frysinger (UNITED STATES)

Message: 62902   

 

look in the whole log for errors

Attachments

    Outcomes