2008-07-12 09:33:18     a compilation error :the type va_list is not recognized !!!

Document created by Aaronwu Employee on Aug 7, 2013
Version 1Show Document
  • View in full screen mode

2008-07-12 09:33:18     a compilation error :the type va_list is not recognized !!!

Oussema Harbi (TUNISIA)

Message: 58723   

 

Hi all,

 

I am trying to compile the latest sources of uClinux ,but am getting this error when executing make :

 

In file included from include/linux/spinlock.h:53,

  from include/linux/capability.h:47,

  from include/linux/sched.h:46,

  from arch/blackfin/kernel/asm-offsets.c:31:

include/linux/kernel.h:123: erreur: expected declaration specifiers or ‘...’ before ‘va_list’

include/linux/kernel.h:127: erreur: expected declaration specifiers or ‘...’ before ‘va_list’

include/linux/kernel.h:131: erreur: expected declaration specifiers or ‘...’ before ‘va_list’

include/linux/kernel.h:135: erreur: expected declaration specifiers or ‘...’ before ‘va_list’

include/linux/kernel.h:139: erreur: expected declaration specifiers or ‘...’ before ‘va_list’

include/linux/kernel.h:155: erreur: expected declaration specifiers or ‘...’ before ‘va_list’

make[2]: *** [arch/blackfin/kernel/asm-offsets.s] Erreur 1

make[1]: *** [prepare0] Erreur 2

make[1]: quittant le répertoire « /home/oussema/uClinux-dist-2008R1-RC8/linux-2.6.x »

make: *** [linux] Erreur 1

 

 

 

Does any one know where  va_list is defined ?Should i install some other libraries ;

 

PS : I tried to replace va_list by char[][] -just to test it - ,the error is now :

 

stdargs.h :unknown file ..

 

Thank you in advance.

 

-Oussema

 

QuoteReplyEditDelete

 

 

2008-07-12 11:31:56     Re: a compilation error :the type va_list is not recognized !!!

Robin Getz (UNITED STATES)

Message: 58725   

 

Oussema:

 

Please go read:

 

https://docs.blackfin.uclinux.org/doku.php?id=faq

 

Building packages fails with stdarg.h missing

 

https://docs.blackfin.uclinux.org/doku.php?id=toolchain:installing#available_packages

 

 

 

=Robin

QuoteReplyEditDelete

 

 

2008-07-12 13:14:17     Re: a compilation error :the type va_list is not recognized !!!

Oussema Harbi (TUNISIA)

Message: 58726   

 

Thank you for answering ,

 

i had a binutils-dev not installed and ncurses ,but i am not going to install ncurses on this system -i already reported a bug on it yesterday https://bugs.launchpad.net/ubuntu/+source/ncurses/+bug/247511.

 

I thought it is used only for the minimal graphic output -like for the bios blue screen-

 

anyway ,i compiled it without errors when i had slackware on my computer ,so am installing a minimal debian system ,that i will use to compile systems.

QuoteReplyEditDelete

 

 

2008-07-12 22:31:52     Re: a compilation error :the type va_list is not recognized !!!

Robin Getz (UNITED STATES)

Message: 58728   

 

Oussema:

 

The min packages for getting going are listed at:

 

https://docs.blackfin.uclinux.org/doku.php?id=installing_linux

Attachments

    Outcomes