2008-07-10 10:09:45     u-bbot flash size error

Document created by Aaronwu Employee on Aug 7, 2013
Version 1Show Document
  • View in full screen mode

2008-07-10 10:09:45     u-bbot flash size error

vijai ragavan (INDIA)

Message: 58625   

 

hai ,

 

i am using M29DW640D70N1 flash chip. my flash chip configuration is

 

#define CFG_FLASH_CFI           /* The flash is CFI compatible */

#define CFG_FLASH_CFI_DRIVER    /* Use common CFI driver */

#define CFG_FLASH_CFI_AMD_RESET

#define CFG_ENV_IS_IN_FLASH     1

#define CFG_FLASH_BASE          0x20000000

#define CFG_MAX_FLASH_BANKS     1       /* max number of memory banks */

#define CFG_MAX_FLASH_SECT      141     /* max number of sectors on one chip */

#define CFG_ENV_ADDR            0x20020000

#define CFG_ENV_SECT_SIZE       0x10000 /* Total Size of Environment Sector */

/* JFFS Partition offset set  */

#define CFG_JFFS2_FIRST_BANK 0

#define CFG_JFFS2_NUM_BANKS  1

/* 512k reserved for u-boot */

#define CFG_JFFS2_FIRST_SECTOR                 8

 

 

the teraterm output is :

 

 

 

U-Boot 1.1.6-svn (ADI-2007R1) (Jul  9 2008 - 18:20:38)

 

CPU:   ADSP BF561

Board: PMP04

Clock: VCO: 486 MHz, Core: 486 MHz, System: 121 MHz

SDRAM: 64 MB

FLASH:   0 kB

*** Warning - bad CRC, using default environment

 

In:    serial

Out:   serial

Err:   serial

Hit any key to stop autoboot:  0

pmp04>

 

in the teraterm output flas is displayed as 0kb. please say your suggestion for getting the flash as 8 MB.

QuoteReplyEditDelete

 

 

2008-07-10 10:35:57     Re: u-bbot flash size error

Robin Getz (UNITED STATES)

Message: 58628   

 

Vijai:

 

I don't think it has anything to do with it - but I think the number of blocks counts from 1, not 0 (it should be 142).

 

To really figure out what is going on, define DEBUG in drivers/cfi_flash.c and send the printout of that.

 

-Robin

Attachments

    Outcomes