2008-06-11 09:29:59     /dev/ppi not found with ppitest

Document created by Aaronwu Employee on Aug 6, 2013
Version 1Show Document
  • View in full screen mode

2008-06-11 09:29:59     /dev/ppi not found with ppitest

tom R (FRANCE)

Message: 56995   

 

Hello !

 

I am beginning on Bf537E and I have compiled my first uClinux last week!

 

I have checked the PPI driver in "Character devices" (xconfig) and configured device_table.txt with the following code:

 

/dev/ppi    c    664    0    0    241    0    0    1    1

 

After a " make image ", I download the new image from my Bf and boot.

 

I want to execute the ppitest program, but I have an Error: opening /dev/ppi: No such file or directory

 

It seems that the driver is not recognized.

 

It would be nice that someone help me.

TranslateQuoteReplyEditDelete

 

 

2008-06-11 10:28:40     Re: /dev/ppi not found with ppitest

Robin Getz (UNITED STATES)

Message: 56999   

 

Tom:

 

What uClinux-dist version are you using? does it work if you create the device by hand (mknod?)

 

Thanks

 

-Robin

QuoteReplyEditDelete

 

 

2008-06-11 10:48:42     Re: /dev/ppi not found with ppitest

tom R (FRANCE)

Message: 57001   

 

I use a  Linux 2.6.22.18-ADI-2008R1-svn release.

 

I wrote now mknod -m 666 ppi0 c 241 0, but the file is protected in read-only mode.

 

I am trying to resolve the problem. I am wondering if the major is really 241 and minor 0.

 

How can I know ?

 

 

 

Thanks

TranslateQuoteReplyEditDelete

 

 

2008-06-11 14:02:34     Re: /dev/ppi not found with ppitest

Mike Frysinger (UNITED STATES)

Message: 57019   

 

please review: http://docs.blackfin.uclinux.org/doku.php?id=uclinux-dist:dev-management

QuoteReplyEditDelete

 

 

2008-06-16 05:30:16     Re: /dev/ppi not found with ppitest

tom R (FRANCE)

Message: 57338   

 

Thank you.

 

I finally found a solution: I changed the file device_table_min.txt with

 

(for ppi)

 

Major: 10

 

Minor:249.

Attachments

    Outcomes