2008-05-23 09:29:20     problem in loading uclinux

Document created by Aaronwu Employee on Aug 6, 2013
Version 1Show Document
  • View in full screen mode

2008-05-23 09:29:20     problem in loading uclinux

yichi zhang (CHINA)

Message: 56211   

 

I use hyper terminal to load bf561-ezkit-2008R1 via the serial port

 

<meta content="text/html; charset=utf-8" http-equiv="CONTENT-TYPE" /> <title></title> <meta content="OpenOffice.org 2.4 (Linux)" name="GENERATOR" /> <style type="text/css"> <!-- @page { size: 21cm 29.7cm; margin: 2cm } P { margin-bottom: 0.21cm } --> </style>

 

when I send the file uImage-bf561-ezkit-2008R1-RC8, which is downloaded from blackfin.uclinux.org

 

all things is ok, and I can see the uclinux welcome interface...

 

hyper terminal shows things like this:

 

ezkit>bootm 0x1000000

 

## Booting image at 01000000 ...

 

Image name: Linux-2.6.22.18-ADI-2008R1-svn

 

Image type: Blackfin Linux Kernel Image

 

Data size: 3356581 Bytes = 3.2 MB

 

Load address: 00001000

 

Entry point: 00140000

 

Verifying checksum ... OK

 

Uncompressing Kernel Image ... OK

 

Starting Kernel at = 140000

 

Linux version 2.6.22.18-ADI-2008R1-svn

 

...successfully boot the uclinux

 

 

 

However, if I use my own images compiled from uClinux-dist-2008R1-RC8 using default settings,it fails to boot.

 

the hyper terminal appear like this:

 

ezkit>bootm 0x1000000

 

## Booting image at 01000000 ...

 

Image name: Linux-2.6.22.18-ADI-2008R1-svn

 

Image type: Blackfin Linux Kernel Image

 

Data size: 3402574 Bytes = 3.2 MB

 

Load Address: 00001000

 

Entry Point: 0014c000

 

Verifying checksum ... OK

 

Uncompressing Kernel Image ... OK

 

Staring Kernel at = 14c000

 

and nothing will continue to appear...

 

 

 

the only difference I can see is Entry Point, one is 140000, the other is 14c000

 

but I have used the default setting to compile ,what cause the different entry point?

 

And how can I load my own compiled files successfully?

 

 

 

Best Regards,

 

TranslateQuoteReplyEditDelete

 

 

2008-05-23 10:44:52     Re: problem in loading uclinux

Robin Getz (UNITED STATES)

Message: 56215   

 

Vichi:

 

It is pretty difficult to tell what the problem is until we get some life on the console.

 

Have a look at:

 

https://docs.blackfin.uclinux.org/doku.php?id=post_mortem

 

 

 

To see where things are dieing.

 

 

 

-Robin

Attachments

    Outcomes