2008-04-26 06:16:25     Issue on uImage

Document created by Aaronwu Employee on Aug 6, 2013
Version 1Show Document
  • View in full screen mode

2008-04-26 06:16:25     Issue on uImage

vijaya joseph (INDIA)

Message: 55020   

 

Hi,

 

I am using Bf561 based embedded hardware. Ic reated Uboot and it is working fine.

 

After that I compiled Uclinux distribution with minimum changes and created uImage.

 

I downloaded the uImage using TFTP. The image was uncompressed properly and starts runnung at 0x100.

 

But after that I didn't see anythig on teratem and instead od root> promprt I am getting falcon> which used by my Uboot.

 

means that proceesor is still in uBoot.

 

Please help me to fix this issue. I couldn't proceed after this for the past two days.

 

How to select the SDRAM chip like MT48LC16M16A2TG_75 using make menuconfig ?

 

I have also attached the config file.

 

The following are the data captured on teraterm

 

U-Boot 1.1.6-svn (ADI-2007R1) (Apr 23 2008 - 16:32:36)

 

CPU:   ADSP BF561

Board: Falcon board

       Support: http://blackfin.uclinux.org/

Clock: VCO: 600 MHz, Core: 600 MHz, System: 120 MHz

SDRAM: 32 MB

FLASH:   8 MB

*** Warning - bad CRC, using default environment

 

In:    serial

Out:   serial

Err:   serial

Net init:    Second

LAN9x18 (0x115a0000) detected at 0x24000000

Hit any key to stop autoboot:  0

falcon> tftp 0x1200000 uImage

start Auto negotiation... (take ~2sec)

Auto negotiation complete, 100BaseTX, full duplex

TFTP from server 172.16.6.135; our IP address is 172.16.15.60

Filename 'uImage'.

Load address: 0x1200000

Loading: #################################################################

         #################################################################

         #################################################################

         #################################################################

         #################################################################

         #################################################################

         #################################################################

         #################################################################

         #################################################################

         #################################################################

         ##########################################

done

Bytes transferred = 3541719 (360ad7 hex)

falcon> bootm 0x1200000

## Booting image at 01200000 ...

   Image Name:   uClinux Kernel and ext2

   Image Type:   Blackfin Linux Kernel Image (gzip compressed)

   Data Size:    3541655 Bytes =  3.4 MB

   Load Address: 00001000

   Entry Point:  00001000

   Verifying Checksum ... OK

   Uncompressing Kernel Image ... OK

Starting Kernel at = 1000

falcon>

 

config

QuoteReplyEditDelete

 

 

2008-04-26 17:19:57     Re: Issue on uImage

Robin Getz (UNITED STATES)

Message: 55026    Vijaya:

 

What version of kernel are you trying to boot? If it is 2008R1 - you need to update your vendor files, and they are out of date. Look at any of the ones in the uClinux-dist for Blackfin.

 

-Robin

QuoteReplyEditDelete

 

 

2008-04-28 00:13:21     Re: Issue on uImage

vijaya joseph (INDIA)

Message: 55081   

 

Hi

 

I am using 2007R1 for my project.

 

Any patches to be updated

 

Vijaya

QuoteReplyEditDelete

 

 

2008-04-28 02:26:34     Re: Issue on uImage

Yi Li (CHINA)

Message: 55082    It is suggested to use 2008r1 release. The vendor files Robin mentioned are located at: uclinux-dist/vendors/AnalogDevices/

 

-Yi

QuoteReplyEditDelete

 

 

2008-04-28 02:30:33     Re: Issue on uImage

Yi Li (CHINA)

Message: 55083    If you want to debug, please refer to: http://docs.blackfin.uclinux.org/doku.php?id=post_mortem. This may help.

Attachments

    Outcomes