2008-04-16 09:28:26     Detecting the flash chip

Document created by Aaronwu Employee on Aug 6, 2013
Version 1Show Document
  • View in full screen mode

2008-04-16 09:28:26     Detecting the flash chip

blue hash (UNITED STATES)

Message: 54334    Hello,

My board: Custom BF537 with a 2 ST320EB flash chips totalling to 4Mb

Uclinux 2008, u-boot-1.1.6

 

In MTD support, my options

<*> Detect flash chips by Common Flash Interface (CFI) probe

< > Detect non-CFI AMD/JEDEC-compatible flash chips        

[ ] Flash chip driver advanced configuration options       

< > Support for Intel/Sharp flash chips                    

< > Support for AMD/Fujitsu flash chips               

<*> Support for ST (Advanced Architecture) flash chips

--- Support for RAM chips in bus mapping              

<*> Support for ROM chips in bus mapping              

< > Support for absent chips in bus mapping  

 

This is what I  get,

physmap platform flash device: 00400000 at 20000000

physmap-flash.0: Found 1 x16 devices at 0x0 in 16-bit bank

Support for command set 0002 not present

gen_probe: No supported Vendor Command Set found

RedBoot partition parsing not available

Using physmap partition information

Creating 4 MTD partitions on "physmap-flash.0":

0x00000000-0x00040000 : "Bootloader"

0x00040000-0x00120000 : "Kernel"

0x00120000-0x003f0000 : "RootFS"

0x003f0000-0x00400000 : "MAC Address"

 

Has the chip been probed successfully? It says found, but then "No supported Vendor Command Set found"

 

Thanks.

QuoteReplyEditDelete

 

 

2008-04-16 11:05:56     Re: Detecting the flash chip

Mike Frysinger (UNITED STATES)

Message: 54349    if the partition map was displayed and you got the device nodes in /dev, then it worked fine

 

the warnings about command sets are normal

Attachments

    Outcomes