2008-04-06 23:26:28     No soundcards found

Document created by Aaronwu Employee on Aug 6, 2013
Version 1Show Document
  • View in full screen mode

2008-04-06 23:26:28     No soundcards found

Bing Han (CHINA)

Message: 53721    My uclinux is uClinux-2008R1-R8

there is error when system boots:

 

Advanced Linux Sound Architecture Driver Version 1.0.12rc1 (Thu Jun 22 13:55:50.

ASoC version 0.13.1

bfin-wm8731: bf5xx_wm8731_init

bfin-wm8731: bf5xx_probe

wm8731: WM8731 Audio Codec 0.13

ALSA device list:

  No soundcards found.

 

why can not find my soubdcard(WM8731)?

 

thanks

TranslateQuoteReplyEditDelete

 

 

2008-04-06 23:57:14     Re: No soundcards found

Mike Frysinger (UNITED STATES)

Message: 53723    you didnt say what hardware you're using

 

we really havent tested any of the wm codecs, so you'll probably have to debug it yourself at this point

QuoteReplyEditDelete

 

 

2008-04-07 00:35:41     Re: No soundcards found

Bing Han (CHINA)

Message: 53727    I use bf561

In 2008R1, it has added support for wm8731 codec(BF527-EZKIT),  it uses I2S and AC97.

AC97 ,I2S and PCM   are not  independent  of  each  other? bf527-ezkit must use ac97 interface?

now  i want to alter that program,make it  run  in my  system(bf561) and  uses  I2S interface?

can i success?

my thought is right?

 

TranslateQuoteReplyEditDelete

 

 

2008-04-07 00:46:49     Re: No soundcards found

Mike Frysinger (UNITED STATES)

Message: 53728    the support added was user contributed and we really havent tested it.  it has known problems.

 

the transport layer was developed for the BF527 ... i imagine you'll need to make changes to make it work on the BF561, or just write your own.

 

we really dont support wolfson codecs here when there are adi codecs available.

QuoteReplyEditDelete

 

 

2008-04-07 23:24:06     Re: No soundcards found

Zhi Qiang Zhang (CHINA)

Message: 53791    I think you did you properly set the SPI configuration.

 

 

Regards,

ZhangZQ

QuoteReplyEditDelete

 

 

2008-04-08 01:29:17     Re: No soundcards found

Bing Han (CHINA)

Message: 53801    thanks for your reply

the problem has been solved.

but when i  test the soundcard , i can not hear anything!

 

root:/tmp> mp3play ./1.mp3

sport-i2s: bf5xx_i2s_startup : sport 0

bfin-wm8731: bf5xx_wm8731_startup

./1.mp3: MPEG1-III (33550 ms)bfin-wm8731: bf5xx_wm8731_hw_params rate 44100 format 2

 

sport-i2s: bf5xx_i2s_set_tx_dai_fmt : fmt 0

sport-i2s: bf5xx_i2s_set_rx_dai_fmt : fmt 0

sport-i2s: bf5xx_i2s_tx_hw_params : sport 0

bfin-wm8731: bf5xx_wm8731_hw_params rate 44100 format 2

sport-i2s: bf5xx_i2s_set_tx_dai_fmt : fmt 0

sport-i2s: bf5xx_i2s_set_rx_dai_fmt : fmt 0

sport-i2s: bf5xx_i2s_tx_hw_params : sport 0

bfin-wm8731: bf5xx_wm8731_hw_params rate 44100 format 2

sport-i2s: bf5xx_i2s_set_tx_dai_fmt : fmt 0

sport-i2s: bf5xx_i2s_set_rx_dai_fmt : fmt 0

sport-i2s: bf5xx_i2s_tx_hw_params : sport 0

sport-i2s: bf5xx_i2s_tx_prepare : sport 0

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 1

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 0

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 1

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 0

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 1

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 0

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 1

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 0

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 1

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 0

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 1

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 0

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 1

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 0

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 1

sport-i2s: bf5xx_i2s_tx_trigger : sport 0 cmd 0

 

where is wrong ?

thanks!

TranslateQuoteReplyEditDelete

 

 

2008-04-09 07:09:23     回复: Re: No soundcards found

Cliff Cai (CHINA)

Message: 53908    Hi,BingH

This discussion maybe have help .

http://blackfin.uclinux.org/gf/project/uclinux-dist/forum/?action=ForumBrowse&forum_id=39&_forum_thread_total_items=50&_forum_thread_page=2&_forum_action=ForumMessageBrowse&thread_id=26446

Cliff

Attachments

    Outcomes