2008-03-25 06:15:28     sd/mmc in cm-bf537e

Document created by Aaronwu Employee on Aug 5, 2013
Version 1Show Document
  • View in full screen mode

2008-03-25 06:15:28     sd/mmc in cm-bf537e

Bastien Briec (FRANCE)

Message: 53003    Hello, i'm trying to use a sd card with the bluetechnix eval board, i compiled the kernel with this parameter :

 

    Device Drivers --->

        MMC/SD Card support --->

            <*> MMC/SD for SPI support (EXPERIMENTAL)

                 (1) SPI chip select signal for MMC/SD card

                 <*> MMC/SD Card detect support (EXPERIMENTAL)

                    (5) Card detect PFx number

 

        File systems --->

            DOS/FAT/NT Filesystems --->

                <*> MSDOS fs support

                <*> VFAT (Windows-95) fs support

                    (437) Default codepage for FAT (NEW)

                    (iso8859-1) Default iocharset for FAT (NEW)

 

        Native Language Support --->

            Base native language support (iso8859-1) Default NLS Option

                <*> Codepage 437 (United States, Canada)

    Main menu Filesystem

        Applications --->

            [*] fdisk

            [*] e2fsck

            [*] mke2fs

            [*] mkdosfs

 

but the sd card is not detected :

 

    root:~> cat /proc/spi_mmc

    Driver build date: Mar 25 2008

    Driver author: Hans Eklund(hans@rubico.se)

    SPI CLK: 400 KHz

    SPI CS : 1

    Error/Status log[0xNEW, 0x0000, 0xOLDEST]. Total: 0

    E:  0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000

    S:  0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000 0x0000

    No MMC/SD card found.

 

Can somebody help me

 

Regards, Bastien

TranslateQuoteReplyEditDelete

 

 

2008-03-25 06:46:38     Re: sd/mmc in cm-bf537e

Hans Eklund (SWEDEN)

Message: 53005    Im not sure if card detection singal really works with all versions of the driver. I would not rely on it. Note also that no card detection is done by reading /proc/spi_mmc, its mearly there for viewing driver status. Try fdisk /dev/spi_mmc to make sure it is opened correctly and that the card init code is run. Create a partition and do mke2fs /dev/spi_mmc1 on it. Dont use the driver with other spi devices active on the bus, it wont work. /Hans

QuoteReplyEditDelete

 

 

2008-03-25 07:00:00     Re: sd/mmc in cm-bf537e

Bastien Briec (FRANCE)

Message: 53006    i try to do fdisk /dev/spi_mmc but i get :

 

    Unable to open /dev/spi_mmc

 

TranslateQuoteReplyEditDelete

 

 

2008-03-26 15:51:37     Re: sd/mmc in cm-bf537e

Frank Van Hooft (CANADA)

Message: 53075    I'd had some trouble getting the SD card working on a BF537-STAMP board, but it's working fine now. Take a look at this thread:

 

http://blackfin.uclinux.org/gf/project/uclinux-dist/forum/?action=ForumBrowse&forum_id=39&_forum_action=ForumMessageBrowse&thread_id=25834

 

for some possible help.

 

Some comments from my experience (don't take these as gospel, this is simply what I found):

 

- I had troubles using the SD card over the SPI Framework driver. I've had much better success using the SPI PIO driver.

 

- Double-check your connections (chip select line etc) to your card. At one point I was using the wrong CS signal.

 

Hope this helps.

Attachments

    Outcomes