2008-02-12 09:26:44     CPU clock Settings and Ethernet device

Document created by Aaronwu Employee on Aug 5, 2013
Version 1Show Document
  • View in full screen mode

2008-02-12 09:26:44     CPU clock Settings and Ethernet device

Thomas Sauter (GERMANY)

Message: 50935    hi,

 

I have changed the Blackfin Clock-Settings (225MHz Core Clock an 90 MHZ system Clock)

Now, I have problems with ethernet.

Every 4-6 hours the Ping RTP go up to >3sec and I have a lot of duplicate pakets. (BF537-stamp Board)

This last about ~5min.

 

any idea?

 

Thanks, thomas

TranslateQuoteReplyEditDelete

 

 

2008-02-13 03:30:35     Re: CPU clock Settings and Ethernet device

Yi Li (CHINA)

Message: 50974    Could you please confirm the "ping" issue does not happen with default BF537-STAMP clock setting (CCLK 500MHz, SCLCK 100MHz) on your board?

 

Also please post the error messages here.

QuoteReplyEditDelete

 

 

2008-02-20 02:31:31     Re: CPU clock Settings and Ethernet device

Thomas Sauter (GERMANY)

Message: 51312    sorry, no error messages.

My stamp board works fine with default settings (500MHz/100MHz). Normal RTP, no duplikate pakets.

 

I change the CCLK to 225MHz and the SCLK to 90MHz for example. (BF537-stamp uClinux-dist.R1.1-RC3)

From time to time (circa 4 hours) the rtp time increase to > 3sec. It takes ca. 10min.

Then the RTP normalize itself for the next period.

In this time, no error message on the board.

The load average is normal. write/read access seems to be normal.

I think, only the ethernet device has problems.

I checked it on two stamp-board. On both boards the same problems.

 

TranslateQuoteReplyEditDelete

 

 

2008-02-25 05:26:19     Re: CPU clock Settings and Ethernet device

Yi Li (CHINA)

Message: 51592    Could you please have a try with 2008R1 branch?

If the problem exists, could you please add a bug in the tracker? Or tell me enough information to report a bug (kernel, toolchain, how to reproduce..).

Thanks,

-Yi

Attachments

    Outcomes