2008-02-08 10:43:02     two problems with CM-BF537E and 2008R1-RC1

Document created by Aaronwu Employee on Aug 5, 2013
Version 1Show Document
  • View in full screen mode

2008-02-08 10:43:02     two problems with CM-BF537E and 2008R1-RC1

Miquel Soler i Mir (SPAIN)

Message: 50855    Hello.

 

I'm using a core CM-BF537E from bluetechnix and 2008R1-RC1 to build the kernel.

 

I have one question and one problem.

 

The question is: Where I can change the baudrate of shell(UART0) ?. With 2007 was 115200 and with 2008 is 57600.

 

The problem is:    I'm trying to connect with the board with telnet and the system answer me this:

mikimonster@miki-toshiba:~$ telnet 192.168.0.32

Trying 192.168.0.32...

Connected to 192.168.0.32.

Escape character is '^]'.

telnetd: All network ports in use.

Connection closed by foreign host.

mikimonster@miki-toshiba:~$

 

I don't know where is the problem.

 

Thanks

 

Miquel Soler i Mir

TranslateQuoteReplyEditDelete

 

 

2008-02-08 11:26:15     Re: two problems with CM-BF537E and 2008R1-RC1

Mike Frysinger (UNITED STATES)

Message: 50857    you control the baud rate like any other system: use the console= kernel command line option

 

the telnet failure is because of the pts options in your kernel being out of sync with the pts options in your dist

QuoteReplyEditDelete

 

 

2008-02-09 09:55:29     Re: two problems with CM-BF537E and 2008R1-RC1

Miquel Soler i Mir (SPAIN)

Message: 50882    Thanks Mike.

 

The first problem I solved changing the baudrate of u-boot to 57600 bps. But this is not the correct way.

When you say me "use the console = kernel command line option", I don't know how I can do it.

 

It's not possible to change this baurdrate in any option of configuration file?

Where I can find the configuration file to change the baudrate or where is the option in make menuconfig?

 

I understand a little bit your proposal for the second problem , but I don't know how to repare it.

 

Can you help me?

 

Thanks

 

Miquel Soler i Mir

TranslateQuoteReplyEditDelete

 

 

2008-02-09 13:04:01     Re: two problems with CM-BF537E and 2008R1-RC1

Mike Frysinger (UNITED STATES)

Message: 50884    no, there is no configuration option for the baudrate.  read about console= in linux-2.6.x/Documentation/kernel-parameters.txt.

 

you have to make sure you have devpts enabled in the kernel and mounted on /dev/pts and CONFIG_USER_TELNETD_DOES_NOT_USE_OPENPTY disabled in your vendor settings.

QuoteReplyEditDelete

 

 

2008-02-10 12:12:20     Re: two problems with CM-BF537E and 2008R1-RC1

Miquel Soler i Mir (SPAIN)

Message: 50890    Thanks Mike

 

The ptsX are no mounted in dev folder.

The number of file descriptors in dev folder is very small compared with 2007 version.

 

No can0, spi_mmc, fb0......

 

I don't know the root of this failure.

 

That do you think about it?

 

Thanks

 

Miquel Soler i Mir

 

 

TranslateQuoteReplyEditDelete

 

 

2008-02-10 17:47:49     Re: two problems with CM-BF537E and 2008R1-RC1

Mike Frysinger (UNITED STATES)

Message: 50894    there is no failure.  device nodes only get created as needed.  if you dont have any device drivers loaded then you dont get any device nodes.

QuoteReplyEditDelete

 

 

2008-02-11 06:14:59     Re: two problems with CM-BF537E and 2008R1-RC1

Miquel Soler i Mir (SPAIN)

Message: 50903    Thanks Mike.

 

There are something that I can't undestand.

 

Why in 2007 kernel the system create the file descriptors(can0,fb0...) and not in 2008?

I'm using the same configuration.

 

The policy of the kernel is the same as 2007 or it goes changed.

 

Thanks

 

Miquel Soler i Mir

TranslateQuoteReplyEditDelete

 

 

2008-02-11 13:15:48     Re: two problems with CM-BF537E and 2008R1-RC1

Mike Frysinger (UNITED STATES)

Message: 50908    you didnt load the device drivers, thus the device nodes would have been useless

 

2008R1+ will only generate device nodes as needed

 

if you want the old static style, pick it in your vendor settings

Attachments

    Outcomes