FAQ: Is there a general overview on using the Disassembly window

Document created by Kader.M Employee on Apr 17, 2018Last modified by Kader.M Employee on Apr 17, 2018
Version 2Show Document
  • View in full screen mode

Disassembly windows display disassembled instructions and symbolic information, which is useful for temporarily modifying the code to test a change or to view code when no source is available. The Disassembly window allows you to examine the assembly code generated by the C/C++ compiler. Symbolic information includes alphanumeric characters representing values and addresses.You can perform the following in the view:

 

• Setting breakpoints at the start of any assembly instruction
• Enabling or disabling breakpoints and setting their properties
• Stepping through disassembled instructions
• Jumping to specific instructions, symbols, or expressions
• Temporarily modifying code in order to test a change or view code when no source is available

 

To explore the Disassembly view:
For CCES: Choose Window > Show View > Other > Debug > Disassembly and click OK.
For VDSP: By default,a Disassembly window appears when you open a new session.If not you can choose View > Debug windows > Disassembly

 

Please refer the below help path for more information on Disassembly windows:

 

If you are using CCES:
CCES help > Help contents > CrossCore® Embedded Studio 2.6.0 > Integrated Development Environment > Navigating Within the IDE > Views > Debug > Disassembly View

 

If you are using VisualDSP++:
VisualDSP help > contents > Graphical Environment > IDDE > Environment >Debug Windows > Disassembly Windows

Attachments

    Outcomes