FAQ: Can't connect to the Blackfin target using DebugAgent

Document created by Kader.M Employee on Apr 17, 2018
Version 1Show Document
  • View in full screen mode

Question:

 

I am using CCES Version, Am unable to connect my Blackfin 537 Target using Debug Agent , Am getting an error message as 

[TpsdkServer] Failed to connect to processor.

Error: 0x80048020
Error Description: Selected emulator not detected

=============================

 

Answer:

 

Please check that the driver is installed properly by checking their computer 'Device Manager'. You should find the EZ-Board listed under 'CrossCore Tools'. Double-click on it to show the driver properties and ensure there are no issues listed.

 

If the EZ-Board is not listed, then problem is with the drivers, Please try reinstalling the drivers. The driver may be found in the "Emu_Drivers" directory in the top directory of the CCES installation. By default this is located at the following path:
<install_dir>\CrossCore Embedded Studio 2.x.x\Setup\Emu_Drivers

 

Also please refer "Installing and Troubleshooting Drivers" in below Troubleshooting Guide:
http://www.analog.com/media/en/technical-documentation/application-notes/EE356.pdf

 

In order to accurately determine the cause of issue, can I ask you the following questions –

 

Does the ICE Test utility run successfully or does it fail at any point? If the Test fails, please provide us with a screenshot showing the ICE Test results.

 

Please ensure that you are you connecting to the EZ-KIT via a USB port native to your PC, if you are using a USB hub, can you try connecting the USB cable from the EZ-KIT directly to the PC. If you are connecting directly to a USB port then try connecting to a different USB port.

 

Have you used this emulator on a custom board or an EZ-KIT board?

 

Do you have another target board you can use to connect? Does the target board still behave the same way? Do you still encounter the same error messages?

 

Please read through our Emulator Troubleshooting Guide and check the troubleshooting steps it advises.
Please refer to the below EE note for CCES.
http://www.analog.com/static/imported-files/application_notes/EE356.pdf

 

Please refer "CCES Install and Session Startup" & "Jumper and Switch Settings" in the below system evaluation manual:
http://www.analog.com/media/en/dsp-documentation/evaluation-kit-manuals/ADSP-BF537_ezkit_man_rev.2.52.pdf

Attachments

    Outcomes