FAQ: ICE-1000 emulator does not recognize custom BF board

Document created by Kader.M Employee on Oct 17, 2017
Version 1Show Document
  • View in full screen mode

Question:

 

I have custom hardware using BF-547 and I am trying to connect the ICE-1000 emulator via JTAG. I have TRST pulled down using 4.7K. The TDI is pulled up using 10K ohms. DSP supplied with  3.3V IO and ICE-1000 configured for 3.3V.

 

I am getting error message ID:  0x80048049. (JTAG not recognizing the DSP).

 

Can you please tell me if there is any specific pull-up, pull-down need to be done for the combination of ICE-1000 and BF-547 DSP.

------------------------

 

Answer:

 

There are a few possibilities why you are encountering this error message. Although you mention your custom board is based on the BF-547, can you please confirm the JTAG section of the board complies with the Analog Devices JTAG Emulation Technical Reference guide, EE-68:
http://www.analog.com/ee68

 

Do you have access to a BF-547 EZ-Kit, or any other type of board? If you do, please let us know if you can connect without any problems to these boards.

 

Have you ever been able to connect to this board without any problems? On occasions, target connection errors can be caused by the processor booting corrupt code. If possible, please try changing the boot mode of the processor and let us know if this has any affect on the behavior you're seeing.

 

Please read through our Emulator Troubleshooting Guide and let us know the results of the troubleshooting steps it advises.

 

Please refer to the below EE note for VDSP++.
http://www.analog.com/static/imported-files/application_notes/EE-175.pdf

 

 

This document was generated from the following discussion: ICE-1000 emulator does not recognize custom BF-547 board

Attachments

Outcomes