AD9830: oscillator

Document created by analog-archivist Employee on Feb 23, 2016
Version 1Show Document
  • View in full screen mode

In my design I'm experiencing oscillator
problems. I'm using AEL1210 integrated
50MHz oscillator.As soon as the AD9830
is connected, the amplitude is between
4V and 5,5V. With the oscillator
driving a 10k resistor, the signal
looks ok. Do I have to take any special
precautions and which oscillator
are you using on the AD9830 demoboard?
Is it normal that the amplitude of the
MCLK degrades if the AD9830 is connected
? Do you have any application notes
regarding oscillator selection for
the DDS chips?

 

We use the IQXO-350 50MHz oscillator module or bench top signal generator with
the AD9830 eval board. The AD9830 MCLK in presents a standard CMOS input
therefore it should not load the oscillator output.

In most cases the actual amplitude of the oscillator output is not important,
and in fact many oscillators do not have nice clean square or sine waves at the
output, the wave form is often distorted. It's also possible that parasitic
capacitance on the input (about 3pF) or on your board is reducing the amplitude
of the oscillator. This is generally not a problem. Frequency stability over
time and temperature are most critical in oscillators.

I assume the AD9830 s working correctly with this crystal. Measure the
frequency of oscillation and if you are satisfied that the frequency is OK, I
would be concerned that the amplitude is slight reduced - provided the waveform
still meets the CMOS switching level.

Attachments

    Outcomes