Problem getting the digital interface to work reliably. Part sporadically goes into power down mode.

Document created by analog-archivist Employee on Feb 23, 2016
Version 1Show Document
  • View in full screen mode

AD7808: Problem getting the digital interface to work reliably. Part
sporadically goes into power down mode.

 

Most likely the digital interface is not reliable. Cust is using a PC based
digital IO card. Possibility of cross talk, PC interuppts,
I have reviewed the schematic and scope plots you sent me and while I do have a
couple of suggestions on you might get the AD7808 up and running correctly, I
cannot see anything inherently wrong with how you are driving the device. I
still strongly suspect that the problem is with the reliability of the digital
signals that are used to drive the AD7808 and that the only real way you are
going to solve this problem is by playing around with the interface. You need
to look for possibilities where the interface may not be seeing 16 falling
edges. A glitch on the clock line would be interpreted as an extra clock or if
the timing of FSEN is such that interface only sees 14 or 15 clocks would put
the interface out of sync. The digital IO box is driven from a PC, is it
possible that an interrupt from the PC causes the IO lines to pause momentarily
and then not resume in the same place?

I have put together a few suggestions which may be worth trying ( not in any
particular order):
? Ensure that you are looking at the CLK, DATA, and FSIN lines directly on the
pins of the AD7808
? I note that on the "Main DAC write" plot you sent me that the data line goes
low between successive 1's. This should not be a problem, however, it’s worth
leaving DATA high between successive 1's to avoid any possibility of not
meeting the required set up and hold times.
? What is the time base on the plots you sent me? I remember you saying that
your clock was operating at 1kHZ or something like that. This might mean you
have very slow edges on the digital interface and you might see double
triggering. Try speeding up the clock rate to a few 100kHz, the max clock speed
is 10MHz.
? Try using a stand alone data generator to drive the AD7808 board.
? The plots you sent look clean but these plots obviously don't show the fault
condition. Try using individual shielded wires for each of the IO lines.
? Look at the layout of your board, Have you got separated digital and analog
ground planes joined at a single point?
? Decoupling caps on the analog and digital power supplies are quite small,
parallel 10uF tantal with the 100nF you have already. Change reference
decoupling caps to 10nF.
? Try adding some isolation between  the analog and digital supplies. This can
be achieved simply by adding a series inductor between the AVDD and DVDD lines.

Attachments

    Outcomes