FAQ: Unable to connect my EndPoint to the ANodeConfig tool.

Document created by NagarjunaG Employee on Sep 23, 2014
Version 1Show Document
  • View in full screen mode

I want to reconfigure my factory configured EndPoint (EP) with new parameters, but I was not able to connect to the ANodeConfig tool. I tried several times in vain. This device is working fine in the network, and I am trying to understand what is preventing the ANodeConfig tool to detect my device.

 

If your End Point device is functioning perfectly fine, and you are unable to connect to the ANodeConfig tool, it sure could be because of a specific setting in the original configuration.


The setting "[ ] Not Sleepy" in the ANodeConfig tool can be used to set a specific device to disable or enable the sleep mode functionality. In your particular case, it is possible that you left the setting open, which means your device is a SLEEPY device as in a deployment scenario.

 

There are two ways to resolve this issue:

1. Network Mode: This works only if the EP is registered in a network. Using the ANodeCenterPoint tool, you can post a "Disable Low Power Mode" message from [Config/commands] window.

 

2. Normal Mode: Go and flash the device again. Open ANodeConfig tool, and configure all the settings. Before saving the configuration, ensure to check the "[v] Not Sleepy" box. Then write the configuration in to the device. You should be all set from now on.


Note: Please make sure to uncheck this box to operate the device in sleep mode. Usually you would need this in a deployment scenario.


 

This FAQ was generated from the following discussion: Unable to connect my EndPoint to the ANodeConfig tool.

Attachments

    Outcomes