FAQ: Upgrading µCOS-III Add-In to version 1.1.0 results in warnings

Document created by CraigG on Jun 11, 2014
Version 1Show Document
  • View in full screen mode

Question

When I upgrade the µCOS-III Add-In in my project to version 1.1.0, I receive multiple warnings that properties do not exist. What is the cause, and can they be ignored?

 

======================================

 

Answer

There is a bug in CrossCore Embedded Studio 1.1.0 that results in some unexpected warnings when upgrading the uCOS-III component to 1.1.0. We are aware of this behaviour, and these warnings can be ignored safely; the resulting project should build without issues.

 

Example Error Output:

Property "uccpu-ucos3-compatibility" required by Add-in "..." doesn't exist

Property "uclib-ucos3-compatibility" required by Add-in "..." doesn't exist

Attachments

    Outcomes