[#6980] qemu fails to compile (Debian Squeeze)

Document created by Aaronwu Employee on Oct 17, 2013
Version 1Show Document
  • View in full screen mode

[#6980] qemu fails to compile (Debian Squeeze)

Submitted By: James Kosin

Open Date

2012-02-29 16:34:27     Close Date

2012-02-29 20:09:32

Priority:

Medium     Assignee:

Nobody

Board:

EZ-Kit Lite     Silicon Revision:

03

Resolution:

Rejected     Fixed In Release:

N/A

Processor:

BF537     

Host Operating System:

coLinux Debian Squeeze

toolchain rev.:

TRUNK / HEAD     kernel rev.:

colinux 2.6.33.7-co-0.7.9

State:

Closed     Found In Release:

N/A

Is this bug repeatable?:

yes     

Summary: qemu fails to compile (Debian Squeeze)

Details:

 

Toolchain fails to compile qemu with Debian Squeeze updated to latest patches/security fixes.

 

I'll be attaching the logs soon.

 

But seems to be complaining about glib-2.0 required to compile QEMU.

 

How to regain compiling of the tools?

 

Follow-ups

 

--- James Kosin                                              2012-02-29 17:14:59

Config logs attached...

 

--- James Kosin                                              2012-02-29 17:16:25

Zipped log file... too large to attached uncompressed.

 

--- Mike Frysinger                                           2012-02-29 20:49:33

you must install dev packages in order to compile things.  please review the

wiki:

http://docs.blackfin.uclinux.org/doku.php?id=installing_linux

 

--- James Kosin                                              2012-03-01 09:09:06

I've installed all the packages before... except the X11 libraries.  coLinux

doesn't have a graphical desktop built in so, I don't need the overhead.

 

I'm checking now after doing:

  apt-get install libgmp3-dev libmpfr-dev

 

 

--- James Kosin                                              2012-03-01 12:36:29

Nope.  Doesn't work.

 

After 3hrs 30min still fails saying QEMU needs glibc-2.0 installed!

 

--- James Kosin                                              2012-03-01 12:44:52

Sorry should have said glib-2.0

 

pkg-config --modversion gthread-2.0

 

is failing.

 

--- James Kosin                                              2012-03-01 12:48:53

maybe need to add

  libglib2.0 and libglib2.0-dev

to the list of required.

 

--- James Kosin                                              2012-03-01 16:22:51

Yup,

 

Need to add:  libglib2.0 and libglib2.0-dev

to the list of required on the web-site.

 

--- Mike Frysinger                                           2012-03-02 01:04:33

i've added libglib2.0-dev to the list ... thanks!

 

 

 

    Files

    Changes

    Commits

    Dependencies

    Duplicates

    Associations

    Tags

 

File Name     File Type     File Size     Posted By

log.zip    application/zip    1896953    James Kosin

config.logs.tbz2    application/octet-stream    1071773    James Kosin

Attachments

Outcomes