2011-05-03 15:14:14     LDR-utils@win fail to work

Document created by Aaronwu Employee on Oct 16, 2013
Version 1Show Document
  • View in full screen mode

2011-05-03 15:14:14     LDR-utils@win fail to work

Jianxi Fu (UNITED STATES)

Message: 100392   

 

Hi all,

 

Could someone give me a help?

 

I try to use my BF537-STAMP to boot "u-boot-bf537-stamp-uart-2010R1-RC2.ldr" by UART.

 

There is no problem when I use ldrviewer1.2

 

                                    

            SW4     Software     Evaluate CTS           

      Test1     1,3 off; 2,4 on     ldrviewer_12     Checked     OK     

      Test2     4 off; 1,2,3 on     ldrviewer_12     UnChecked     OK     

                                    

 

Test2 is with hardware flow control while Test1 is without it

 

However, when I try to use bfin-uclinux-ldr from "blackfin-toolchain-win32-2010R1.exe", it fail to work.

 

Loading LDR u-boot-bf537-stamp-uart-2010R1-RC2.ldr ... OK!

Opening /COM1... OK!

Configuring terminal I/O ... OK!

Trying to send autobaud ... OK!

Trying to read autobaud ... OK!

Checking autobaud ... OK!

Autobaud result: 115200bps 49.766mhz (header:0xBF DLL:0x1B DLH:0x00 fin:0x00)

Sending blocks of DXE 1 ... [1

 

The program stop here. Could someone give me a help?

 

Thank you very much!

 

Jianxi

QuoteReplyEditDelete

 

 

2011-05-04 03:59:45     Re: LDR-utils@win fail to work

Stuart Henderson (UNITED KINGDOM)

Message: 100411   

 

Hi Jianxi,

 

This is a known problem with the 2010R1-RC4 release.  There is a problem with the bfin-*-ldr included with this release.  I am currently working on a hot-fix for this which I will release in the next couple of days.  However, if you need a fix before then, you can use the bfin-*-ldr from the previous release:

 

blackfin-toolchain-09r1.1-2.i386.tar.bz2

 

I hope this resolves your problem.

 

Stu

QuoteReplyEditDelete

 

 

2011-05-04 10:05:51     Re: LDR-utils@win fail to work

Stuart Henderson (UNITED KINGDOM)

Message: 100419   

 

Hi Jianxi,

I have attached a hot-fix patch for the windows ldr in 2010R1.  You should just be able to unzip it in to your install directory and it will replace the following files:

 

elf/bin/bfin-elf-ldr.exe

elf/bin/bfin-ldr.exe

uclinux/bin/bfin-uclinux-ldr.exe

uclinux/bin/bfin-ldr.exe

linux-uclibc/bin/bfin-linux-uclibc-ldr.exe

linux-uclibc/bin/bfin-ldr.exe

 

Feel free to back these up should you wish to revert to them at a later stage.

 

Please let me know if this resolves your problem.

 

Thanks,

Stu

 

blackfin-toolchain-win32-2010R1-ldr-hotfix-20110504.zip

QuoteReplyEditDelete

 

 

2011-05-04 14:20:13     Re: LDR-utils@win fail to work

Jianxi Fu (UNITED STATES)

Message: 100425   

 

Hi Stuart,

 

Thanks for your help.

 

However, I am sorry that they still do not work.

 

I have tried both 2009R1 and hot-fix version.

 

Both of them can successfully transfer data:

 

Loading LDR /tftpboot/u-boot.ldr ... OK!

Opening /COM1 ... OK!

Configuring terminal I/O ... OK!

Trying to send autobaud ... OK!

Trying to read autobaud ... OK!

Checking autobaud ... OK!

Autobaud result: 115200bps 49.766mhz (header:0xBF DLL:0x1B DLH:0x00 fin:0x00)

Sending blocks of DXE 1 ...OK!

You may want to run minicom or kermit now

Quick tip: run 'ldrviewer <ldr> <tty> && minicom'

 

 

However, when I open Windows terminal program, nothing response.

 

Could you check my hardware and command line?

 

Without hardware flow control:

SW4: 1,3 off; 2,4 on

bfin-ldr -l u-boot-bf537-stamp-uart-2009R1-rc3.ldr /COM1

 

With hardware flow control:

SW4: 4 off; 1,2,3 on

bfin-ldr -l -C u-boot-bf537-stamp-uart-2009R1-rc3.ldr /COM1

 

Neither of them work. When I switch back to ldrviewer1.2 everything is OK.

 

Expressing appreciation for all your cares and concerns on this.

 

 

regards

 

Jianxi

QuoteReplyEditDelete

 

 

2011-05-13 13:35:25     Re: LDR-utils@win fail to work

Stuart Henderson (UNITED KINGDOM)

Message: 100651   

 

Hi Jianxi,

 

Sorry for the delay in replying.  I've reproduced the problem you are seeing and it is caused by the serial port not being configured properly.  I wasn't seeing it before as something else must have been leaving it in an appropriate state.

 

Could you try the attached hot-fix (same instructions as last time) and let me know if this resolves your problem?

 

Thanks again,

 

Stu

 

blackfin-toolchain-win32-2010R1-ldr-hotfix-20110513.zip

QuoteReplyEditDelete

 

 

2011-05-18 16:59:06     Re: LDR-utils@win fail to work

Jianxi Fu (UNITED STATES)

Message: 100728   

 

Hi Stuart,

 

Now it works fine!!

 

Expressing appreciation for all your cares and concerns on this.

 

By the way, where can I get the source code of the files you provided?

 

With best

 

Jianxi

QuoteReplyEditDelete

 

 

2011-05-20 08:24:50     Re: LDR-utils@win fail to work

Stuart Henderson (UNITED KINGDOM)

Message: 100778   

 

Hi Jianxi,

 

I'm glad it's working for you!

 

i'm afraid the source for the ldr (ldr-utils) is currently only available in our svn repository:

 

http://blackfin.uclinux.org/gf/project/toolchain/scmsvn

 

or our git repo:

 

http://blackfin.uclinux.org/git/?p=readonly-mirrors/toolchain.git

 

It will also be available in the 2011R1 BETA1, which should be released next week.

 

thanks,

 

Stu

Attachments

    Outcomes