2011-08-09 05:57:24     Toolchain crash while building uClinux Distro

Document created by Aaronwu Employee on Oct 16, 2013
Version 1Show Document
  • View in full screen mode

2011-08-09 05:57:24     Toolchain crash while building uClinux Distro

Chandrashekhar Lavania (INDIA)

Message: 102863   

 

Hi,

 

I am using 2010R1-RC4 toolchain with 2010R-RC5 uClinux distribution. I was in the process of building my uClinux distro with Fedora 14 as Host OS, when my toolchain crashed.

 

I had fired make -s at uClinux-dist/

 

I got the following trace from fedora:

 

 

 

 

 

Package:     blackfin-toolchain-2010R1-RC4

Latest Crash: Tue 09 Aug 2011 01:30:21 PM

Command:     /opt/uClinux/bfin-uclinux/lib/gcc/bfin-uclinux/4.3.5/../../../../bfin-uclinux/bin/as -mnopic -mcpu=bf527-0.2 -o kernel/semaphore.o /tmp/ccShNEpf.s

Reason:     Process /opt/uClinux/bfin-uclinux/bfin-uclinux/bin/as was killed by signal 11 (SIGSEGV)

Comment:     None

Bug Reports:

 

[New Thread 18472]

Core was generated by `/opt/uClinux/bfin-uclinux/lib/gcc/bfin-uclinux/4.3.5/../../../../bfin-uclinux/b'.

Program terminated with signal 11, Segmentation fault.

#0  0x08054308 in ?? ()

 

Thread 1 (Thread 18472):

#0  0x08054308 in ?? ()

No symbol table info available.

#1  0x08054575 in ?? ()

No symbol table info available.

#2  0x08061f96 in ?? ()

No symbol table info available.

#3  0x08062065 in ?? ()

No symbol table info available.

#4  0x08061ff1 in ?? ()

No symbol table info available.

#5  0x08061aa1 in ?? ()

No symbol table info available.

#6  0x08051eb4 in ?? ()

No symbol table info available.

#7  0x08052767 in ?? ()

No symbol table info available.

#8  0x0805d88b in ?? ()

No symbol table info available.

#9  0x0805d971 in ?? ()

No symbol table info available.

#10 0x0805a624 in ?? ()

No symbol table info available.

#11 0x0804bf5b in ?? ()

No symbol table info available.

#12 0x0804c11d in ?? ()

No symbol table info available.

#13 0x00aabe36 in __libc_start_main (main=0x804bfa0, argc=6, ubp_av=0xbfe07894, init=0x80bbe70, fini=0x80bbea0, rtld_fini=0xa7ecf0 <_dl_fini>, stack_end=0xbfe0788c) at libc-start.c:226

        result = <value optimized out>

        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {12693492, 0, 0, -1075808152, -361878934, 2147106068}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x6, 0x80497d0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 6}}}

        not_first_call = <value optimized out>

#14 0x080497f1 in ?? ()

No symbol table info available.

From        To          Syms Read   Shared Object Library

0x00aabc10  0x00bc89e4  Yes         /lib/libc.so.6

0x00a70850  0x00a87acf  Yes         /lib/ld-linux.so.2

$1 = 0x0

No symbol "__glib_assert_msg" in current context.

eax            0x0 0

ecx            0x6 6

edx            0xb7426538 -1220385480

ebx            0xd3ff50c8 -738242360

esp            0xbfe07550 0xbfe07550

ebp            0xbfe07568 0xbfe07568

esi            0x34b0495 55248021

edi            0x8095238 134828600

eip            0x8054308 0x8054308

eflags         0x210282 [ SF IF RF ID ]

cs             0x73 115

ss             0x7b 123

ds             0x7b 123

es             0x7b 123

fs             0x0 0

gs             0x33 51

No function contains program counter for selected frame.

 

 

I was unable to recreate this issue as after doing a 'make clean' when I  tried to rebuilt the uClinux distro, it all went fine.

 

What may be the cause of this issue. Is it related to the Host OS or toolchain?

 

Do we need to file it as a tracker item?

 

Any pointers will be helpful.

 

Regards,

Shekhar

QuoteReplyEditDelete

 

 

2011-08-09 09:25:13     Re: Toolchain crash while building uClinux Distro

Stuart Henderson (UNITED KINGDOM)

Message: 102868   

 

Unfortunately, if I can't reproduce it then there's not much point in opening a tracker.  if it happens again and you can provide a test case or instructions so we can reproduce then please do let us know.

 

Perhaps someone on the uclinux-help board may be able to help with this?

 

http://blackfin.uclinux.org/gf/project/uclinux-dist/forum/?action=browseRedirect&action=ForumBrowse&forum_id=39

 

however, if everything's working for you now after a make clean, then it could just have been some crud in your build directory?

 

Stu

Attachments

    Outcomes